compiz config settings "crashes" display

Bug #426651 reported by haran_elessar on 2009-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
New Wave
Medium
Dilomo

Bug Description

As I stated on the theme's page at gnome-look ( http://tinyurl.com/58zyew ). Dilomo requested I reported the bug here with more details, especially hardware details. So first here is my system info

-Computer- : HP Pavilion dv6000
Processor : 2x Genuine Intel(R) CPU T2250 @ 1.73GHz
Memory : 1017MB
OS : Ubuntu 9.04
-Display-
Resolution : 1280x800 pixels
OpenGL Renderer: Mesa DRI Intel(R) 945GM 20090326 2009Q1 RC2 x86/MMX/SSE2
New Wave version 0.8.1, manually installed

 it seems the compiz config file that is suggested in the theme enables the blur effects. When I used the suggested settings every object in my desktop became black. Every window, the panels and even gnome-do, to the point where I couldn't see anything. Everything was working (as I could call Do, write logout and hit enter and gnome would log out) the thing is I couldn't see anything. When logging back in everything would seem normal for around 3 seconds and then things would start turning black one by one.

I really had no idea what setting caused the issue. I was able to resolve it by resetting gnome's settings via the terminal before login. A few weeks after that I was playing around with the compiz settings and I turned on blur to see how this computer would handle that effect. To my surprise the same thing happened again, but I was lucky and I had time to uncheck the box before I couldn't see anything. the good thing was that I was able to identify the problem.

so if the blur effects were really the cause of the problem, I suggest they shouldn't enabled on the suggested settings by default but instead recommended.

Dilomo (ankere) wrote :

This seems to be an issue with your video card drivers but that in no way is your fault but the absence of good drivers. One possible solution would be to apply blur only to some windows rather than everyone. For example apply blur only to the panel of Gnome Do and the terminal's background if transparent. I can't think of other uses of blur with New Wave enabled. Still this is not the optimal solution as users may think that this is problem with the apps themselves. Turning blur off is not good because the settings for compiz are optional and thus you enable them if you want more eyecandy. Probably I can make a list of incompatible drivers and put it in the README file with some other notes. What do you think?

Changed in anton:
assignee: nobody → Dilomo (ankere)
importance: Undecided → Medium
milestone: none → newwave-0.8.2
status: New → Confirmed
haran_elessar (david-spike) wrote :

Yeah I think a warning should suffice. I know the README already has a warning but at least, in my case, I decided to try it out since I thought that the worse that could happen was ending up with a very slow framerate. I know blur is heavy and can turn things super slow on the wrong computer, but I had never used it on the laptop I'm currently using so I didn't know it behaved that way.

I'm not an ubuntu expert but I really wouldn't like a complete newbie to have the same problem that I did. In that sense, a warning in the README, stating that blur may cause some serious problems on certain computers because of driver incompatibility should be all right.

Dilomo (ankere) on 2009-11-09
Changed in anton:
status: Confirmed → In Progress
Dilomo (ankere) on 2009-12-14
Changed in anton:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints