"ValueError: Ciphertext too large" when decrypting message

Bug #892540 reported by aj00200
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Anonplus
High
aj00200

Bug Description

recv: ('\x88\xebM7)+D3\x96\xc2\x89\xf8\x9b<\xbe\xe6\xc3R\x17l@\xb8h\x92\xd9\xb9Qxx\x17\x15\xe8\xe75\x16E\x97\xb5\xe8\x84Lt\x12\x14R0\xd9\x8eh\x9a\x90\x99u.\x00w\xa2\xb4\xce\xe1\x0ft6\\\x81_\\B\xea\xad\xcd\x08L\x88\x82\xc0\x17_\xcd\x1b\x08\xabm9\xa3\xed*q\x0ea\x18HU(7\xb6\xcb\xabc\xadR\x9f\xd2N\x12\n\x86\x11b\xe2^+\xbaS\xb3\xae\x9b\xc9\xe3QO\x88V\x9b\xcd\xbc!\x839h\xf2\xf3#\xe1\x92\x05\x0fS\xbf\x91\x95{\t\xc4\xa8\xf3N\x9d\xf1\xa3\x0c\xf5\xd3\x81+\x99b\xc7.\xeb\r{\x8c\xef-\\ +\xedQ\xd0\xdb\x0fI7\x86\x17\xc3\x1f\xddH\x18L3l\xb8\x87\xbf\xaa`\xaa\x1c~\xca\xb7\x19+\xcb\x16\xd4\x8am\xab\t*\xb3\xbe%\xd3\xb5@\xfcQ\xa9\xf4\x01\xd5T\xc1\xce\xc9\x94\xb6P\xa4\x9f\xa4\xacS\x99\x10\xaf_\x90\xfa?\xd5\xba!\xb9\x16\xf0\xa0\x14\xd86C\x98\x87Ir<\\v\xcc\xcd',)
parsing packets of Aj00200
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "/home/aj00200/vomun/src/tunnels/directudp.py", line 51, in run
    friend.parse_packets()
  File "/home/aj00200/vomun/src/libs/friends.py", line 87, in parse_packets
    self.__decrypt()
  File "/home/aj00200/vomun/src/libs/friends.py", line 186, in __decrypt
    self.data = self.encryption.decrypt(self.data)
  File "/home/aj00200/vomun/src/libs/encryption/rsa.py", line 29, in decrypt
    return keys[self.source].decrypt(data)
  File "/usr/lib/python2.7/dist-packages/Crypto/PublicKey/pubkey.py", line 77, in decrypt
    plaintext=self._decrypt(ciphertext)
  File "/usr/lib/python2.7/dist-packages/Crypto/PublicKey/RSA.py", line 68, in _decrypt
    return self.key._decrypt(ciphertext)
ValueError: Ciphertext too large

Revision history for this message
aj00200 (aj00200) wrote :

It appears that the data is being sent as a tuple rather than as a string and that it is messing up decryption on the remote host because of the data from the tuple formatting. I have tried to remove this data before sending the packet but it is still being introduced somewhere else.

Revision history for this message
aj00200 (aj00200) wrote :

I managed to get the text to send without the tuple formatting and I managed to get it to decrypt but as soon as I put the most up to date code on both my computers, it stopped working. I'm trying to work out the problem now.

Revision history for this message
aj00200 (aj00200) wrote :

Bug fixed in ~vomun-developers/anonplus/vomun-trunk » Revision 150

Changed in anonplus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers