Not works in Ubuntu 16.04

Bug #1553518 reported by costales on 2016-03-05
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ANoise
Critical
costales
Ubuntu
Undecided
Unassigned

Bug Description

ANoise 0.0.25 doesn't work on Ubuntu 16.04.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04
Codename: xenial

$ apt-cache policy anoise
anoise:
  Installed: 0.0.25
  Candidate: 0.0.25
  Version table:
 *** 0.0.25 500
        500 http://ppa.launchpad.net/costales/anoise/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/costales/anoise/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status

$ anoise
/usr/share/anoise/anoise.py:20: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, Gst
/usr/share/anoise/anoise.py:20: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, Gst
Traceback (most recent call last):
  File "/usr/share/anoise/anoise.py", line 24, in <module>
    from preferences import Preferences
  File "/usr/share/anoise/preferences.py", line 21, in <module>
    from gi.repository import Gtk, WebKit
ImportError: cannot import name WebKit

Installing the package python-webkit doesn't help.

costales (costales) on 2016-03-05
Changed in anoise:
status: New → Confirmed
costales (costales) on 2016-04-06
Changed in anoise:
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → costales (costales)
Belenos (belenos) wrote :

Same problem here.

I get this error message when I try to load the app:

/usr/share/anoise/anoise.py:20: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, Gst
/usr/share/anoise/anoise.py:20: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, Gst
Traceback (most recent call last):
  File "/usr/share/anoise/anoise.py", line 21, in <module>
    from dbus.mainloop.glib import DBusGMainLoop
ImportError: No module named dbus.mainloop.glib

I have the ppa enabled.

Belenos (belenos) wrote :

Any news on this bug?

Joshua Fogg (joshua-h-fogg) wrote :

I've found a work around (http://stackoverflow.com/questions/7823972/cant-import-webkit-from-gi-repository) which gets the program launching and playing noise for me, even if other bugs persist which prevent me picking which noise gets played.

Belenos (belenos) wrote :

I've found another (and easier) solution! Just had to install python-dbus from the ubuntu repositories and now anoise-gui is launching again and working fine.

sudo apt-get install python-dbus

Robert Orzanna (orschiro) wrote :

Dear Rafael,

I have python-dbus installed but it doesn't solve the problem for me.

Warmly,

~Robert

Belenos (belenos) wrote :

Hey, Robert! Try this:

sudo gedit /usr/share/anoise/anoise.py

Go to line 19:

import gi, os, threading

Change to the following lines and save it:

import gi, os, threading
gi.require_version('Gtk', '3.0'), gi.require_version('Gst', '1.0')

Now:

sudo gedit /usr/share/anoise/preferences.py

Got to line 21:

from gi.repository import Gtk, WebKit

Remove the comma and "WebKit" at the end and save it.

Now try to open "anoise" from Terminal and see if there's still any error.

Robert Orzanna (orschiro) wrote :

Hi Rafael,

Thanks a lot!

It successfully starts the noise but I can't see any indicator.

Any idea why the indicator is not showing up?

Thankfully,

~Robert

Belenos (belenos) wrote :

That's a known problem with the new API, I guess. I have no idea on how to fix it, but I'm using the anoise-gui instead and it's working just fine :)

Robert Orzanna (orschiro) wrote :

Well, maybe we can somehow get the indicator back to work.

This would be just great. :)

Warmly,

~Robert

Belenos (belenos) wrote :

Which DE are you using, Robert? Unity, Gnome,...?

Robert Orzanna (orschiro) wrote :

Dear Rafael,

I'm using Unity, and you?

~Robert

costales (costales) wrote :

It's not in the repository.

Changed in ubuntu:
status: New → Invalid
Glenn Moloney (g-moloney) wrote :

Hi I'm a Unity desktop user & the indicator appears in my sound menu but when you click on the play button nothing happens... I can open the app & play the sounds but it would be great if it could be controlled from the indicator like 14.04. Any updates / news on this working possibly?

Thanks for a great app!!!

olivier08 (olivier08) wrote :

Hi,

If you have this problem:

   from dbus.mainloop.glib import DBusGMainLoop
ImportError: No module named dbus.mainloop.glib

you can solve it doing:

sudo apt-get install --reinstall python-dbus

~olivier08

Aaron (apelly) wrote :

Searching for a solution to this has led me to this ticket. I thought it was something I'd broken myself.

Anyway, I also found a commit to fix what seems to be the same issue in Nuvola Player:

https://github.com/tiliado/nuvolaruntime/commit/33b8c893565bfa7dae2434bf03175f30b0cc8dfe

It may be of interest?

costales (costales) wrote :

Hi, Please could you try again (with version 0.0.26)? Thanks in advance!

PS: I'm forcing a GUI for control the play. I need to investigate the prev/forward controls as integrated in the plugin systray.

Changed in anoise:
status: In Progress → Fix Released
Alin Andrei (nilarimogard) wrote :

This doesn't seem fixed. For me it occurs in Ubuntu 17.04 with Anoise 0.0.26:

Traceback (most recent call last):
File "/usr/share/anoise/anoise.py", line 23, in <module>
from dbus.mainloop.glib import DBusGMainLoop
ImportError: No module named dbus.mainloop.glib

Alin Andrei (nilarimogard) wrote :

I spoke too soon, simply installing python-dbus fixed that. But then the following error occured:

$ anoise
Traceback (most recent call last):
  File "/usr/share/anoise/anoise.py", line 26, in <module>
    from preferences import Preferences
  File "/usr/share/anoise/preferences.py", line 22, in <module>
    gi.require_version('WebKit', '3.0')
  File "/usr/lib/python2.7/dist-packages/gi/__init__.py", line 118, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace WebKit not available

This was fixed by installing gir1.2-webkit-3.0.

Now Anoise works, but only via its GUI. Trying to use it from the Ubuntu Sound Indicator doesn't work: clicking play there doesn't do anything.

Alin Andrei (nilarimogard) wrote :

After a session restart, clicking the play button in the Ubuntu Sound indicator results in the Anoise GUI window opening and Anoise does work. But it cannot be controlled from the indicator, only the Anoise GUI.

costales (costales) on 2017-06-12
Changed in ubuntu:
status: Invalid → Fix Released
status: Fix Released → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers