anoise not launching - webkit problem

Bug #1458686 reported by dan on 2015-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ANoise
Undecided
Unassigned

Bug Description

I installed anoise on a freshly installed xubuntu core installation and nothing seemed to happen. It did not get added to the sound menu as it did on my previous xubuntu installation.
I tried running it from the cli to see if there were any messages and this is what I got:

user@linux:~$ anoise
Traceback (most recent call last):
  File "/usr/share/anoise/anoise.py", line 24, in <module>
    from preferences import Preferences
  File "/usr/share/anoise/preferences.py", line 21, in <module>
    from gi.repository import Gtk, WebKit
ImportError: cannot import name WebKit

The problem seems to be in the preferences files. And without that it doesn't work.

Hi Dan!
I think Xubuntu Core is just the basic libraries and in your case, you
need this library at least:
sudo apt-get install gir1.2-webkit-3.0

Could you confirm me if that worked?
Thanks in advance!

dan (danielmc) wrote :

Great!! You were absolutely right.
That solve the problem straight away.

Thank you so much.

You are welcome :)

--
---
Costales

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers