Support for other DE

Bug #1440242 reported by Moo on 2015-04-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ANoise
Undecided
Unassigned

Bug Description

Please add support for other desktop environments as well. Currently I'm using MATE. When I launched player, I can only hear sound but can not stop or switch track.

Moo (mooo) on 2015-04-03
description: updated
costales (costales) wrote :

Hi Moo! I'm using MATE too. The screenshot in the webpage is already in Ubuntu MATE.

What is happen if you click in the sound notification? Here: http://i.imgur.com/x9HBCBQ.png

Expect just an entry in the sound notification :) Like this:
http://i.imgur.com/x9HBCBQ.png

ANoise Player will appear just in the sound indicator and it will appear only in there!
You'll not find a window or other things ;)

The launcher in your applications is need for just the first run, because that launcher will create the entry in the sound notification in that first run. You will not need to launch it again :)

costales (costales) wrote :

Could you post here the exist of this command too? Open a Terminal and run:
apt-cache search indicator-sound

Moo (mooo) wrote :

The post of command is:
indicator-sound - System sound indicator.
indicator-sound-gtk2 - System sound indicator.

Actually I think my system installation is a little bit messed up. Earlier I think I used to have such sound menu. But now all I see is a sound slider. Not sure now if it's a bug or my fault. :)
Anyways thank you for great indicator and your quick reply.

costales (costales) wrote :

Your packages are OK. Which are you distro and version?

costales (costales) on 2015-04-05
Changed in anoise:
status: New → In Progress
costales (costales) wrote :

 It's done:
http://goo.gl/yNx0RU

Install ANoise 0.0.16:
sudo apt-get install anoise
and the 'extra' window:
sudo apt-get install anoise-gui

I'm so sorry, but don't expect a great window player, it'll be just a simple window for change the noise :) And it'll not be syncronize with the sound indicator.

This anoise-gui is just for Ubuntu MATE 14.10+ or GNOME Shell.

Could you confirm me if all is working as expected? Thanks!

Changed in anoise:
status: In Progress → Fix Released

Using anoise in Kubuntu 15.04, and anoise-gui was needed (and works) here too, inspite of the use of several deprecated functions.
Plasma5 compatibility would be highly appreciated.

Moo (mooo) wrote :

Using Ubuntu MATE 14.10. Installed anoise-gui. Everything seems to be fine.
Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions