anbox cloud error: Failed to initialize LXD

Bug #2024559 reported by chaowen guo
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Anbox Cloud
Fix Released
Simon Fels

Bug Description

I want to install anbox cloud in oracle cloud arm machine and follow and get:
sysctl: setting key "net.ipv4.ping_group_range": Invalid argument
2023-06-21 10:37:11 LXD is ready, continuing with its initialization
ERROR: Storage pool size of 0GB is too small. Need >= 15GB

the machine is with 2core 12gb memory and df -h show:
Filesystem Size Used Avail Use% Mounted on
tmpfs 1.2G 1.6M 1.2G 1% /run
/dev/sda1 49G 11G 39G 21% /
tmpfs 5.9G 48M 5.8G 1% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
/dev/sda15 98M 5.1M 93M 6% /boot/efi
tmpfs 1.2G 20K 1.2G 1% /run/user/1001
tmpfs 1.0M 0 1.0M 0% /var/snap/lxd/common/ns

Please help!!!

I run the following command: sudo anbox-cloud-appliance.buginfo
and get in the attachment anbox.txt

Revision history for this message
chaowen guo (chaowenguo) wrote :
Revision history for this message
Alexis Janon (ajanon) wrote :

Hi, thanks for the report.

In the logs, I can see
ERROR: Bootstrap has previously failed, not running again

Have you tried to install the anbox-cloud-appliance before? If you did, could you try again in a cleanly installed VM?

Please ensure that you do not initialize LXD, let Anbox Cloud manage the LXD cluster on your VM.

Changed in anbox-cloud:
status: New → Triaged
Revision history for this message
Simon Fels (morphis) wrote (last edit ):

> /dev/sda1 49G 11G 39G 21% /

You need more space on the root volume if you do not use a separate block disk for the container storage. Minimum is 100GB on the root disk which will let the appliance automatically choose ~20GB for an on disk loop image for the storage pool (see That will let you run a 2-5 containers in parallel, depending on their storage requirements.

> ERROR: Storage pool size of 0GB is too small. Need >= 15GB

We get the 0GB here as we expect at least 40GB free disk space. If we don't see that, we fail with this error.

There is still a bug in here as the we have a check when you run `anbox-cloud-appliance init` which should already fail if this is the case.

Simon Fels (morphis)
Changed in anbox-cloud:
assignee: nobody → Simon Fels (morphis)
milestone: none → 1.18.2
importance: Undecided → Medium
Alexis Janon (ajanon)
Changed in anbox-cloud:
status: Triaged → Fix Committed
Gary.Wang (gary-wzl77)
Changed in anbox-cloud:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.