amd

Report features for AMD processors

Bug #960461 reported by Boris Ostrovsky on 2012-03-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amd
Medium
Chris Van Hoof
linux (Ubuntu)
Medium
Tim Gardner
Precise
Medium
Tim Gardner

Bug Description

New AMD processors support Core Performance Boost (CPB), Read-Only APERF/MPERF and Translation Cache Extensions (TCE). These two commits from mainline make kernel report these features correctly and should be backported to 12.04:

   969df4b82904a30fef19a67398a0c854d223ea67
   652847aa449cfe364d40018849223f57f31a38e2

Tim Gardner (timg-tpi) on 2012-03-21
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
assignee: nobody → Tim Gardner (timg-tpi)
Chris Van Hoof (vanhoof) on 2012-03-21
Changed in amd:
status: New → Fix Committed
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in amd:
assignee: nobody → Chris Van Hoof (vanhoof)
visibility: private → public
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package linux - 3.2.0-21.34

---------------
linux (3.2.0-21.34) precise; urgency=low

  [ AceLan Kao ]

  * SAUCE: (drop after 3.4) asus-wmi: add scalar board brightness adj.
    support
    - LP: #961879
  * SAUCE: (drop after 3.4) asus-wmi: store backlight power status for AIO
    machine
    - LP: #961880

  [ Andy Whitcroft ]

  * [Config]: enable CONFIG_DRM_LOAD_EDID_FIRMWARE

  [ John Johansen ]

  * SAUCE: AppArmor: Add the ability to mediate mount
  * SAUCE: AppArmor: Add profile introspection file to interface
  * SAUCE: AppArmor: basic networking rules
  * SAUCE: Update aufs for build failure caused by apparmor backport
  * SAUCE: AppArmor: Fix change_onexec when called from a confined task
    - LP: #963756

  [ Leann Ogasawara ]

  * Revert "SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux
    device"
  * Rebase to v3.2.13
  * d-i: Fix iwl3945 driver name typo in nic-modules
  * d-i: Add missing iwl* drivers to nic-modules
    - LP: #965116
  * d-i: Remove obsolete bcm43xx* drivers from nic-modules
  * d-i: Add brcm*mac drivers to nic-modules

  [ Seth Forshee ]

  * SAUCE: (drop after 3.3) apple_bl: Add register/unregister functions
  * SAUCE: (drop after 3.3) platform/x86: Add driver for Apple gmux device

  [ Tim Gardner ]

  * Add isci to debian scsi-modules udeb
    - LP: #963306
  * SAUCE: fsam7400: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233

  [ Upstream Kernel Changes ]

  * Bluetooth: Adding USB device 13d3:3375 as an Atheros AR3012.
    - LP: #916319
  * x86: Report cpb and eff_freq_ro flags correctly
    - LP: #960461
  * x86/amd: Add missing feature flag for fam15h models 10h-1fh processors
    - LP: #960461
  * KVM: Move cpuid code to new file
    - LP: #960466
  * KVM: expose latest Intel cpu new features (BMI1/BMI2/FMA/AVX2) to guest
    - LP: #960466
  * apparmor: add missing rcu_dereference()
  * apparmor: fix module parameter handling
  * btrfs, nfs, apparmor: don't pull mnt_namespace.h for no reason...
  * switch security_path_chmod() to umode_t
  * switch securityfs_create_file() to umode_t
  * switch ->path_mkdir() to umode_t
  * switch ->path_mknod() to umode_t
  * capabilities: remove the task from capable LSM hook entirely
  * switch security_path_chmod() to struct path *
  * AppArmor: refactor securityfs to use structures
  * AppArmor: add initial "features" directory to securityfs
  * AppArmor: add "file" details to securityfs
  * AppArmor: export known rlimit names/value mappings in securityfs
  * AppArmor: Add mising end of structure test to caps unpacking
  * AppArmor: Fix dropping of allowed operations that are force audited
  * AppArmor: Fix underflow in xindex calculation
  * AppArmor: fix mapping of META_READ to audit and quiet flags
  * AppArmor: Fix the error case for chroot relative path name lookup
  * AppArmor: Fix error returned when a path lookup is disconnected
  * AppArmor: Fix oops in policy unpack auditing
  * AppArmor: Add const qualifiers to generated string tables
  * AppArmor: Retrieve the dentry_path for error reporting when path lookup
    fails
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in amd:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers