amd

Usb 3.0 device is recognized as usb 2.0 device on usb 3.0 port if the port has been used by usb 3.0 device after booted

Bug #1322409 reported by Anthony Wong on 2014-05-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Gavin Guo
amd
Undecided
Unassigned
linux (Ubuntu)
Undecided
Gavin Guo
Trusty
Undecided
Unassigned

Bug Description

Summary:
After booted, when using usb 3.0 device first time, it can be recognized as usb 3.0 device correctly.
But after that, usb 3.0 device are recognized as usb 2.0 device on same port.
Usb 3.0 device should be "SuperSpeed USB", "high-speed USB device" means usb 2.0 device.

Information in dmesg:

[ 86.462345] usb 6-1: new SuperSpeed USB device number 2 using xhci_hcd
[ 86.479502] usb 6-1: Parent hub missing LPM exit latency info. Power management will be impacted.
[ 86.481741] usb 6-1: New USB device found, idVendor=125f, idProduct=312b
[ 86.481748] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 86.481754] usb 6-1: Product: ADATA USB Flash Drive
[ 86.481758] usb 6-1: Manufacturer: ADATA
[ 86.481763] usb 6-1: SerialNumber: 23221115500102A9
[ 86.542060] Initializing USB Mass Storage driver...
[ 86.542305] scsi2 : usb-storage 6-1:1.0
[ 86.542453] usbcore: registered new interface driver usb-storage
[ 86.542457] USB Mass Storage support registered.
[ 87.541874] scsi 2:0:0:0: Direct-Access ADATA USB Flash Drive 1.00 PQ: 0 ANSI: 6
[ 87.542976] sd 2:0:0:0: [sdb] 15433728 512-byte logical blocks: (7.90 GB/7.35 GiB)
[ 87.543126] sd 2:0:0:0: [sdb] Write Protect is off
[ 87.543133] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 87.543281] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[ 87.543635] sd 2:0:0:0: Attached scsi generic sg2 type 0
[ 87.548847] sdb: sdb1 sdb2 sdb3
[ 87.549916] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[ 104.344017] WARNING! power/level is deprecated; use power/control instead
[ 104.498216] usb 6-1: USB disconnect, device number 2
[ 113.833843] usb 5-1: new high-speed USB device number 3 using xhci_hcd
[ 113.884757] usb 5-1: New USB device found, idVendor=125f, idProduct=312b
[ 113.884766] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 113.884772] usb 5-1: Product: ADATA USB Flash Drive
[ 113.884776] usb 5-1: Manufacturer: ADATA
[ 113.884781] usb 5-1: SerialNumber: 23221115500102A9
[ 113.886137] scsi3 : usb-storage 5-1:1.0
[ 114.886319] scsi 3:0:0:0: Direct-Access ADATA USB Flash Drive 1.00 PQ: 0 ANSI: 6
[ 114.888157] sd 3:0:0:0: Attached scsi generic sg2 type 0
[ 114.889087] sd 3:0:0:0: [sdb] 15433728 512-byte logical blocks: (7.90 GB/7.35 GiB)
[ 114.889289] sd 3:0:0:0: [sdb] Write Protect is off
[ 114.889302] sd 3:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 114.889918] sd 3:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[ 114.895224] sdb: sdb1 sdb2 sdb3
[ 114.896844] sd 3:0:0:0: [sdb] Attached SCSI removable disk

Steps:
1. Boot into system
2. Connect a usb 3.0 storge device to usb 3.0 port
3. Disconnect the device
4. Connect a usb 3.0 storge device(you can use the same device) to same port again

Expected results: Usb 3.0 device is recognized as usb 3.0 device

Actual results: Usb 3.0 device is recognized as usb 2.0 device

Image: stella-yuanli-precise-amd64-20131114-0

CPU: AMD A4-5000 APU with Radeon(TM) HD Graphics (4x)

GPU: 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8330]

Manufacturer: Hewlett-Packard

ProductName: HP 14 Notebook PC

BiosVersion: F.07

tags: added: blocks-hwcert-enablement
tags: removed: blocks-hwcert-enablement
Gavin Guo (mimi0213kimo) on 2014-07-28
Changed in amd:
assignee: nobody → Gavin Guo (mimi0213kimo)
status: New → In Progress
information type: Proprietary → Public
Changed in linux (Ubuntu):
assignee: nobody → Gavin Guo (mimi0213kimo)
Changed in amd:
assignee: Gavin Guo (mimi0213kimo) → nobody
Gavin Guo (mimi0213kimo) on 2014-07-28
Changed in linux (Ubuntu):
status: New → In Progress
Changed in hwe-next:
status: New → In Progress
Changed in amd:
status: In Progress → Triaged
Changed in hwe-next:
assignee: nobody → Gavin Guo (mimi0213kimo)
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Gavin Guo (mimi0213kimo) on 2014-08-20
tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: added: verification-done
removed: verification-done-trusty
Brad Figg (brad-figg) on 2014-08-20
tags: added: verification-done-trusty
removed: verification-done
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: New → Fix Released
Gavin Guo (mimi0213kimo) on 2014-09-03
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in hwe-next:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers