Tracks in Various Artists Albums aren't grouped together

Bug #319494 reported by Jmadero on 2009-01-21
62
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Amarok
Confirmed
Wishlist
amarok (Ubuntu)
Low
Unassigned

Bug Description

SUMMARY:

This is a metabug for tracking the various artists issue in Amarok 2 on Ubuntu. The issue (in short) is this: Amarok does not group tracks from a multiple-artist album together. This causes a single album (for example, the Now That's What I Call Music series) to appear as multiple albums, each with one track by a particular artist. Expected behavior (as occurred in Amarok 1.4), is that these types of albums will be grouped together in the album view.

ORIGINAL REPORT:

Hi All,

I have included an image for this one. My mix cd's (bought from stores) are coming up as multiple listings in the playlist for Albums despite them being the same album. The image shows two albums listed twice each (not songs listed twice, it's like the songs are split despite being same album.)

Jmadero (jmadero) wrote :
bittajam (bittajam) wrote :

Yes, I confirm.
I've got the same thing.
Some albums looks fine, and some (without any logic) - just like that.

Amarok 1.4 gave me the possibility to drag and drop such things from one album to another, but Amarok 2 doesn't provide such feature, wich would be very useful.

Robin (robinchew) wrote :

Same here, the collection is showing multiples of the SAME album as seen in attached pic.

Robin (robinchew) wrote :

I suspect that it is sorting by album AND ARTIST as seen in my attached pic.
It shows 3 groups of the same album name.
The differentiating factor seems to be the artists for each group.

But really it should be just 1 group.

Robin (robinchew) wrote :

You will also end up with many Unknown albums.

Jmadero (jmadero) wrote :

I've actually went back to 1.4 almost completely because of this problem :( I also have a few wish list items posted, hoping that in the next few months 2* is a bit more stable and consistent

Version: 2.1.1 (using KDE 4.2.4)
OS: Linux
Installed from: Debian testing/unstable Packages

"Various artists" albums that have an "album artist" tag filled should appear
in the collection tab under the specified album artist, not under the "Various
Artists" generic name. In my case, these "album artist" tags are automatically
filled by Picard.

At the moment, when I'm looking for albums released by a DJ, I expand said DJ
name in the collection tab and only her "official" releases are shown there. I
also have to search under "Various Artists" to see her mix or compilation
releases, which I find inadequate and rather difficult since her name is not
displayed there.

Andrew Ash (ash211) wrote :

You guys are right, there are issues with various artist support now in Amarok 2. Luckily, the developers are aware of the problem and discussions are being made about the best way to handle the issue [1] [2].

From the screenshots posted it looks like Amarok is splitting the compilation album up into each of the artists that took part in the album. Does this look like a fair assessment?

To move forward with getting better various artists support, let's make sure we're all on the same page. What version of Amarok were you running here, Jmadero? (apt-cache policy amarok) Make sure you're fully updated and we'll try to get a coherent message about what the problem is to the upstream developers.

Thanks!

[1] http://mail.kde.org/pipermail/amarok/2009-March/008128.html
[2] http://mail.kde.org/pipermail/amarok/2008-December/007397.html

Changed in amarok (Ubuntu):
status: New → Incomplete
Andrew Ash (ash211) on 2009-07-19
summary: - Multiple Listings for Same Album
+ Various Artists issue: Multiple Listings for Same Album

sorry for the delayed response. I've been out of town the last couple of weeks and am just now getting things back together in the next couple of days so I'll be able to get all the requested information. Thank you much!

Jmadero (jmadero) wrote :

I'm back on track so here is the information you requested:

apt-cache policy amarok
amarok:
  Installed: 2:2.1.1mysql5.1.30-0ubuntu1~jaunty1
  Candidate: 2:2.1.1mysql5.1.30-0ubuntu1~jaunty1
  Version table:
 *** 2:2.1.1mysql5.1.30-0ubuntu1~jaunty1 0
        500 http://us.archive.ubuntu.com jaunty-backports/main Packages
        100 /var/lib/dpkg/status
     2:2.0.2mysql5.1.30-0ubuntu3 0
        500 http://us.archive.ubuntu.com jaunty/main Packages

As for your question about if it's separating based on artist...I'm finding it really hard to determine exactly what it is doing. In my case I have the Now That's What I Call Music series (about 10 of them at least). About 80% of them are listing under various artists under the correct album name and everything, the other 20% is listing under the artist instead but the order is Artist -> Album (which is the "Now That's....") -> Song Title

So, it's not being consistent at all which is strange as all of these are the same cd series.

*** Bug 90095 has been marked as a duplicate of this bug. ***

*** Bug 184612 has been marked as a duplicate of this bug. ***

*** Bug 195661 has been marked as a duplicate of this bug. ***

*** Bug 137756 has been marked as a duplicate of this bug. ***

*** Bug 109084 has been marked as a duplicate of this bug. ***

this bug should be intended as "problems handling various artists name" or multiple artist per song
i really don't think it is a duplicate of bug #90095

Andrew Ash (ash211) on 2009-08-03
summary: - Various Artists issue: Multiple Listings for Same Album
+ Tracks in Various Artists Albums aren't grouped together
description: updated
Changed in amarok:
status: Unknown → New

Per Myriam's bug triage report on the mailing list yesterday [1], it appears that this bug has become the meta-bug for tracking the various artist issue that Amarok has now.

The same issue is popping up in Ubuntu's bug tracker several times as well [2]. I'm linking that bug to this one, for easier communication between upstream and downstream.

Let's work together to try to get this mess fixed!

[1] http://mail.kde.org/pipermail/amarok-devel/2009-August/004521.html
[2] https://bugs.edge.launchpad.net/ubuntu/+source/amarok/+bug/319494

*** Bug 205236 has been marked as a duplicate of this bug. ***

neoeno (neoeno) wrote :

I have discovered a workaround. Amarok only seems to get confused with compilations if the tracks are in different folders. The procedure goes thus:

- Click 'Show Under Various Artists' on every duplicated album until they all appear under Various Artists (as in Robin's image)
- On one of the albums (they should all be complete albums), click 'Organise Files'.
- Update collection.

neoeno (neoeno) wrote :

Seems there may be a bit of confusion regarding what is going on here. Maybe another explanation will help:

I note that a compilation album has been split up into individual artists, rather than being grouped under Various Artists. I right click one of the albums, and click 'Show Under Various Artists'.

All the tracks in that album _of the artist selected_ now appear under Various Artists. All other tracks remain under the individual artists.

So I go to each of the artists, click 'Show Under Various Artists' for the album.

The result is that we have as many duplicate listings of the compilation under Various Artists as there were artists when the album was split up into artists. All of these duplicate albums contain all of the tracks in the album.

If I Rescan Collection, then the compilation returns to its original state, with the compilation distributed over many artists.

(All of this depending, I hypothesize, as per my workaround, on the folder in which the tracks are located. If all of the tracks are located in the same folder, everything works as it should. If not, the above situation occurs.)

Changed in amarok (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Low

Changing version. Since I don't use that tag at all, can somebody confirm this is still valid in current 2.2-git?

(In reply to comment #9)
> Changing version. Since I don't use that tag at all, can somebody confirm this
> is still valid in current 2.2-git?

yes, it's

*** This bug has been confirmed by popular vote. ***

Why remove me from CC?

Alex, why did you remove all those people from the CC?

*** Bug 214229 has been marked as a duplicate of this bug. ***

I can confirm this bug exactly as neoeno described it. His workaround worked for me as well.
But the behavior of amarok should be change, so that no workaround is needed.

My amarok version:
Version 2.2.0 (KDE 4.3.2)

Ivan D Vasin (nisavid) wrote :

this issue was reported at [1] and claimed to be "RESOLVED as FIXED" with amarok-2.1.1. hopefully it will be reopened and really fixed soon.

[1] https://bugs.kde.org/show_bug.cgi?id=172953

Jmadero (jmadero) wrote :

I've gone back to Amarok 1.4 because of the issues with various artists in 2...the issues were quite a bit bigger than I thought:

1. Grouping is wrong as described in this post

2. Sometimes if I mark an album as "remove from various artists" amarok either refuses to remove it, or removes it but upon restart they are back in various artists

this is one of many many bugs that I've encountered in Amarok 2, so this is just one of the contributing factors for me to go back to 1.4 which has always been solid for me.

Other issues related to various artists:

With my own mixes that show up in Various Artists I can't get wiki or lyrics but using the same exact files in 1.4 I get both, no problem at all (tags are all right)

Can't display things under various artists AND under their own artists, it's one or the other, it'd be nice to have the option to have both as sometimes I want to see my album but sometimes I want to go to the artists and see the files there

Changed in amarok:
status: New → Confirmed
Robert Persson (ireneshusband) wrote :

Why has this been assigned a low priority? A music player should enable you to effortlessly browse your collection and choose albums to listen to. This behaviour makes that impossible, as should be clear from the comments of those who have already said they will be going back to version 1.4. Speaking for myself, I have just re-upgraded, having gone back to 1.4 some time ago, and I'm starting to regret doing so because of this.

Jmadero (jmadero) wrote :

If you look at their list of bugs you'll see that all in all...this one is relatively minor. They are more concerned with amarok crashing with sig faults and then I know they are working on some feature requests that are pretty critical (such as playlist support for mp3 players, MTP devices, etc...), unfortunately there aren't a lot of developers so they have to prioritize and, despite me agreeing with you that this is annoying, it's not critical and the music player is still functional with the bug...

Created attachment 42455
ID tag example

Hi,

Please see my attachment. This is still an issue in Amarok 2.3.0.

Cheers

Samkit (samjam86) wrote :

I also got this issue when I added new albums.
But for me it got resolved when I updated full collection from "Setting -> Configure Amarok -> Collection -> Fully Rescan entire collection".

I am using "Amarok 2.3.0".

fundriver (fundriver) wrote :

I also can confirm this bug and im actually like "wtf?" that this bug only has a low importance. Actually me and somebody else dont use Amarok anymore because of this bug - because the sorting as Various Artist that now doesnt work anymore is a key-future for me.

This should be solved in the upcoming Amarok 2.3.2.

Created attachment 51879
Example mp3 music file

It seems that you have different testing data that me (us?). You can check ID tag in KID3. Amarok still takes Album Artist as the Artist.

This bug is unfortunately still present. Please reopen this issue. Cheers

Sorry, but I think there is some confusion on your behalf: in your file, the Album Artist is set to "Various Artist" for exactly that purpose: to make it show under Various artists and not under the individual artist, since it is part of a various artist compilation. If you don't want that, don't set it.
There is another bug not showing the Artist in the Various artists compilations in the Collection browser, but that is a completely different bug: #228876

Wojciech Ryrych (ryrych) wrote :

When 1st level in local collection is artist, the second album, the one with various artists should be grouped as a one album.
Confirmed with newest Amarok (today's appearance in Kubuntu repositories) 2.3.2.

Perhaps it is really misunderstanding on my part but I have double checked and my playlist is displaying Album artist tag instead of Artist. I have checked my layout if I've included Album artist instead of Artist. It seems that I am using Artist in my layout, however my playlist displays Album artist. Are we talking here about the same thing?

Album artist is used for compilations, and it is correctly read and used to filter the track into Various Artists. If you don't want it to filter that, then remove that tag entry.
The fact that the artist name is not displayed in the various artist track is another bug, see my earlier comment.

In every case where I have run into this "bug" -- it has actually been incorrect tagging. If Various Artists is correctly set as the Album Artist, and the Album name is identical for all the tracks, all the tracks will correctly be sorted as an Album in VA. If people prefer to see all tracks sorted with the artists, they shouldn't use the Album Artist tag. The developers have correctly left the organization up to the users, since some prefer it one way, and some prefer it the other.

Using a good tagging app before moving the album into the collection is a wise move. I prefer Picard, but EasyTag and Kid3 have their advocates also.

Created attachment 52005
Screenshot

Thanks Myriam,

Would you please confirm that the bug you are referring to (#228876) is also valid for the playlist layout? Because in playlist layout Artist tag displays Album artist tag (which is wrong behaviour).

Would you be also so kind and reconfirm the bug number as it seems that #228876 is not relevant bug report.I've searched 'Various artist' and found 15 bugs which none of them seems relevant. Just to make it sure please see my attachment of the playlist layout. All relevant info is marked with red square.

I have tested the same file (the one from the attachment) in plenty of other media players:

Bangarang,
Clementine,
Kaffeine,
SMPlayer,
Juk,
Dragon player,
Xine,
VLC,
Audacious,
Totem,
Exaile

and all of them are showing this tag correctly. They are showing Artist tag and not Album artist tag like Amarok.

Also all ID tag viewers/editors (Kid3, EasyTag, Mediainfo, Entagged) correctly show actual Artist under Artist tag and not Various artist from the Album Artist tag.

If you think/believe that this is not the same bug then I will report another one.

I can enclose sample of this file I have tested with but it has the same information as the one i've attached in one of my previous posts.

Cheers,

D.

Changed in amarok:
status: Confirmed → Fix Released

I think this bug has returned in 2.4 beta 1.

I have tried this with two albums ("Dj Kicks: Erlend Øye" and "Ratatat Remixes vol 2"), they both show the same behaviour:

When album artist is set, they show up under each individual track artist. If I select album -> show under various artists, the album artist tag is cleared from the files (which would make some sort of sense if the actually showed up under album artist correctly). If I try to set album artist again, I'm back to square one with the tracks spread out over several artists.

Audun,
the whole behaviour is a little bit tricky. By definition (Amaroks definition) a compilation has no album artist.
Which explains why your album artist is cleared if you select "show under variouis artists".

Another behaviour is; if you sort your collection by album/artist or artist/album, then the artist in question is always the album artist and not the track artist.

Another behaviour is that, if no album artist is set, then the track artist is used as album artist.

To make a long story short: please scan the directories in question with the amarokcollectionscanner application and attach the output here (please don't scan your whole collection, the result would be too large for a bug entry).

Ralf,

Thanks, your answer provides a good explanation, and a workaround/fix:
If I click the wrench icon in the collection panel and select "first level" -> "album artist" everything seems to work as expected. I just wasn't aware that this option was available. If I select "Artist / Album" from the drop down, the collection is sorted by track artist (in contrast to album artist as I think you think it should be?). I guess this behavior makes sense as it is, but maybe album artist would be a more reasonable default option?

The clearing of the album artist field makes perfect sense, but maybe a warning would be appropriate?

I'm pasting the first entry of the output in case it still matters:
<?xml version="1.0" encoding="UTF-8"?>
<scanner count="1">
    <!--Created by amarokcollectionscanner 2.3.90onSun Dec 12 02:43:24 2010-->TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.

    <directory>
        <path>/home/audun/mp3/E/Erlend Øye/2004 DJ-Kicks</path>
        <rpath>mp3/E/Erlend Øye/2004 DJ-Kicks</rpath>
        <mtime>1292075426</mtime>
        <track>
            <uniqueid>ddae817869d1f3841cd827cdad71fb5b</uniqueid>
            <path>/home/audun/mp3/E/Erlend Øye/2004 DJ-Kicks/01. So Weit Wie Noch Nie.mp3</path>
            <rpath>mp3/E/Erlend Øye/2004 DJ-Kicks/01. So Weit Wie Noch Nie.mp3</rpath>
            <filetype>1</filetype>
            <title>So Weit Wie Noch Nie</title>
            <artist>Jürgen Paape</artist>
            <albumArtist>Erlend Øye</albumArtist>
            <album>DJ Kicks: Erlend Øye</album>
            <noCompilation/>
            <year>2004</year>
            <track>1</track>
            <bitrate>253</bitrate>
            <length>224000</length>
            <samplerate>44100</samplerate>
            <filesize>7110295</filesize>
            <mtime>1292085938</mtime>
            <trackGain>0.605</trackGain>
            <trackPeakGain>-6.91106</trackPeakGain>
            <albumGain>0.335</albumGain>
            <albumPeakGain>-6.91106</albumPeakGain>
        </track>

Cool.

Now We just need to improve the stupid level selection. Nobody understands that.
Not unless you read the code, and even the code is very complex.

Reopening based on latest comments.

*** Bug 259576 has been marked as a duplicate of this bug. ***

Changed in amarok:
status: Fix Released → Confirmed
Changed in amarok:
importance: Unknown → Medium
Fuujuhi (fuujuhi) wrote :

Just installed Amarok 2.4 from lucid-backports, and afaict the "single album / multiple artists" problem is solved.

I only had to delete the current playlist + do full collection rescan. Now all tracks belonging to the same album are listed together. Also in the playlist there is an additional column giving the track artist if it is not the same for all.

does it make sense to change "First Level --> Album Artist" to be the default? i can think of several reasons for it, and none against it. most importantly:

  * with "First Level --> Artist", it's painstaking to put an album under "Various Artists" (for reference, or for playing the whole album in order) unless the track artist is the same throughout the album. with some genres and release types, seeing different track artists within an album is the most common case.

  * users are typically more likely to know the album artist than the particular combination of collaborating artists on each track.

  * having tens or hundreds of albums under "Various Artists" makes it impractical to browse them without filtering. sorting the first level by album artist reduces the count, especially with well tagged tracks.

perhaps the level selection can be made clearer, or perhaps the sorting can be improved by some redesign. i think those improvements should be the topics of separate bug reports. until then, changing the default dimension for first level sorting would provide a major improvement for most users.

i also suggest renaming "First Level --> Artist" to "First Level --> Track Artist" to avoid ambiguity and confusion. after all, album artists are also artists.

Renaming the bug, I think that all mentioned problems had a root in somehow unfortunate default Collection browser display mode. (correct me if I'm wrong)

Changed in amarok:
importance: Medium → Wishlist

It seems that it still does not work when compilation is set. The album appears under Various Artists instead of the album artist name.

Rohan Garg (rohangarg) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. But don't worry! This issue is being tracked by the KDE developers at: https://bugs.kde.org/show_bug.cgi?id=199483. Once fixed in KDE, it will be included in Kubuntu once the KDE version the fix is in in reaches Kubuntu.

Thanks!

Changed in amarok (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.