alsaconf missing from alsa-utils

Reported by Rocco Stanzione on 2006-01-24
40
Affects Status Importance Assigned to Milestone
Alsa utilities
Invalid
Undecided
Unassigned
alsa-utils (Ubuntu)
Medium
Unassigned

Bug Description

The alsaconf utility seems to have been deliberately omitted from alsa-utils. I can't imagine why, but there is a comment in debian/rules making it clear that it's no accident. This tool makes life easier for users of ISA soundcards and for myself as a user of multiple soundcards (it automates the selection of the sound card and driver to use). Could we restore this functionality to the package? Thanks.

Rocco Stanzione (trappist) wrote :

Discovered this thread explaining the motivation for removing alsaconf:
http://www.ubuntuforums.org/showthread.php?t=52941
I'd like to add that I see a lot of support traffic on #ubuntu wondering where alsaconf is. They come from other distros, or they read documentation online that tells them to run it. While ubuntu has arguably better solutions for sound configuration, and while alsaconf apparently introduces some packaging difficulty, it's a useful utility and I think its inclusion would solve more problems (from an end-user point of view) than it causes (from a maintainer perspective).

Craig Sampson (ubuntu-psi-aus) wrote :

I agree with this comment. I had a look at the abovementioned ubuntuforums thread and whilst I, as a non-developer would find it hard to argue the techincal merits of doing sound card setups one way or another way it seems to me that those of us still running ISA sound cards have very little opportunity to easily set them up.

From the ubuntuforums thread above, from Thomas Hood:

"...however, that alsaconf continues to have some value as a
hardware detector and as a diagnostic aid."

For me, keeping a modified version of alsaconf that does no more than spit out a diagnostic/hardware detection text file or even just spitting relevent stuff to stdout would be a big bonus when trying to configure ISA sound.

It may well be that the world has moved on and automagic ISA sound configuration is no longer easily maintainable, particularly given what must be a pretty small audience these days, but I hate seeing goods tools put aside completely without a full function replacement - not to mention that most alsa related documents still talk about the alsaconf tool.

Cheers,
Craig

Changed in alsa-utils:
status: Unconfirmed → Rejected
Matt Zimmerman (mdz) wrote :

alsaconf was originally removed from Ubuntu because it broke the module-init-tools configuration in terrible ways.

According to one of the Debian alsa-utils maintainers, alsaconf is planned for removal from Debian as well. It is no longer needed for configuring the ALSA drivers. Its only remaining use is for debugging. If your sound doesn't work out of the box, but works after running alsaconf, this is a bug which should be reported.

Thomas Hood (jdthood) wrote :

Re: "alsaconf is planned for removal from Debian"

Speaking for the Debian ALSA packaging team I'd like to clarify our position. alsaconf is a poorly written and poorly maintained program. Even if it were well written and well maintained, we would prefer to have ALSA packages that worked properly without the administrator have to run a configuration utility every time there is a hardware change. We have almost realized this ideal. However, we continue to get reports that say "Sound doesn't work unless I run alsaconf!". When sound doesn't work unless the user runs alsaconf it means:

* The user's system isn't configured properly. Probably a module name needs to be added to /etc/modules or something.
* The alsaconf utility provided the user with some useful information, even though in an ideal world it wouldn't be needed.

We don't plan to remove alsaconf from Debian soon. However, I am leaning toward changing the program so that it doesn't write out any files, but only prints out debugging information. (The files that it writes out now are superfluous in most cases.) The first thing it will print is "This is a debugging utility. Under normal circumstances you do not need to run alsaconf to configure your system to use ALSA."

Rocco Stanzione (trappist) wrote :

Thanks, Thomas, for the clarification. That's exactly what I was hoping for in lieu of restoring alsaconf to the ubuntu package. Meanwhile I've been harping on users to file bugs relevant to this issue so we can either demonstrate that alsaconf is still needed or develop a solution that truly deprecates it.

Martin Pitt (pitti) wrote :

BTW, the handling of multiple sound card has been improved vastly in Breezy with the automatic handling of newly added sound cards at runtime and the Gnome Audio selector. This feature is now even more robust in Dapper.

Martin Pitt (pitti) wrote :

Rejecting this bug; what we actually need are bug reports about particular sound cards that fail.

Changed in alsa-utils:
status: Unconfirmed → Rejected

I disagree Martin. Its sux i need report my soundcard isnt working because have no tool to configure my card... I agree with the closement, but compile some guide to configure boards without alsaconf...

Need info about how to install sound cards without alsaconf.

Changed in alsa-utils:
status: Rejected → Needs Info

Changing priority to impulse the compilation of some documentation, and indication of it for anothers bugs.

Daniel T Chen (crimsun) wrote :

Please don't adjust the severity and priority. We know about the bug and its duplicate(s) and are working on a solution.

Changed in alsa-utils:
status: Needs Info → In Progress
status: In Progress → Rejected
usr (usrlp) wrote :

alsaconf is really necessary to configure an ISA non plug & play cards, for example.

Inlude alsa-utils with alsaconf now, please! In the CD of the distribution or in reporitories!

Thank you!

usr (usrlp) wrote :

Unnofficial packages for *buntu Dapper & Edgy of alsa-utils with alsaconf (by Pjotr) are avialable here:

http://ubuntuforums.org/showthread.php?t=311166&highlight=Installing+ALSA

pangO (pango) wrote :

What about the Hardy Heron and above? I've got intel hd audio soundcard and can't configure it. even installing newest alsa version (1.0.20) didn't help me. Is some alternative package?

DaVince (vincentbeers) wrote :

I'd like to add to this old bug by mentioning that Xfce and subsequently Xubuntu do NOT have any ALSA audio configuration utitlies that come with the system. This is perhaps something to look at.

alsaconf is deprecated by udev/hal. The detection is automatic. If
module options is needed by some card, it must to be configured in
/etc/modprobe.d/alsa-base.conf

DaVince escreveu:
> I'd like to add to this old bug by mentioning that Xfce and subsequently
> Xubuntu do NOT have any ALSA audio configuration utitlies that come with
> the system. This is perhaps something to look at.
>
>

--
Leonardo Amaral - Administrador de Sistemas Linux
Cerificado LPIC-2 LPI000106747 (Verificador hgwxf77vau)
Tel: +55 31 8542-7467 / +55 31 4062-7411
--
Leonardo Amaral - Linux System Administrator
LPI ID: LPI000106747 Level 2 certified (Verifier hgwxf77vau)
Tel: +55 31 8542-7467 / +55 31 4062-7411

Tobin Davis (gruemaster) on 2011-03-04
Changed in alsa-utils:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers