Subwoofer not working in Intel Macbooks

Reported by Ricky Campbell on 2008-12-06
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ALSA driver
New
Unknown
Mactel Support
Medium
Unassigned
linux (Ubuntu)
Low
Unassigned
Nominated for Karmic by Lennart Regebro
linux-backports-modules-2.6.31 (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Lennart Regebro

Bug Description

Upon installation of Ubuntu 8.10, sound can be enabled by adding
"options snd_hda_intel model=mbp3"
to /etc/modprobe.d/options
(This is needed due to a detection issue, but that is another bug)
After rebooting, the sound does work, but there is no sound from the Macbook's built-in subwoofer which makes the sound very poor sounding in comparison to how it sounds in OSX. This difference puts Ubuntu in a bad light. Users often complain about "tinny" or "poor quality" sound.

This is specifically occurring on Macbook4,1 models (and likely Macbook3,1 as well)

Reference:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4086
http://sourceforge.net/mailarchive/message.php?msg_name=4935B32D.3060501%40forestfactory.de

Changed in mactel-support:
importance: Undecided → Medium
status: New → Confirmed
David Murrell (david-murrell) wrote :

"options snd_hda_intel model=mbp3"

This is posted to the end alsa bug report, but I figure since I wrote it, then I should be able to post it where ever I like :)

On my Macbook 4,1, running a stock Ubuntu 8.10, kernel 2.6.27-11-generic, alsa version 1.0.17
The magic options bit that makes bass work on mine is a kernel option when inserting the snd_hda_intel module:

model=asus-a7m

The PCM level seems to control some(all, maybe) of the bass woofer. I'm not sure if all of the woofer is entirely all there though. Might be, would need to get two macbooks next to each other with the same piece of music to see. My hunch is that it isn't. Its more bassy than than the auto detected config, however.

To make this change permanent, do this
sudo gedit /etc/modprobe.d/options
Add the line:
"options snd_hda_intel model=asus-a7m"
Save, Quit
Reboot

Sound should work.

I'm not promising that it's perfect, either. I have no idea about recording, or iec playback, or even if plugging in a headset turns off the speakers, or causes global thermonuclear war, only that it increases the bass somewhat.

Niels Ganser (niels.io) wrote :

A fix for MacBook 3,1 has now been applied to the ALSA codebase. It's commit 4afdf938d581df426de5161b33899db1f95b88de in alsa-kernel. E.g. http://git.alsa-project.org/?p=alsa-kernel.git;a=commit;h=4afdf938d581df426de5161b33899db1f95b88de

Would anyone like to take a stab at backporting this patch to ALSA 1.0.18 so it can be put into jaunty-updates?

Lennart Regebro (regebro-gmail) wrote :

This bugfix has been released in ALSA 1.0.21. Please, please, please, make Karmic use 1.0.21, so we get proper MacBook support.

Alex Murray (alexmurray) wrote :

The subwoofer in my MacBook Pro 5,1 works fine under Karmic - Lennart have you actually tried Karmic to see if it works on your machine? Unfortunately Karmic will not use 1.0.21, you'll have to wait for Lucid

Lennart Regebro (regebro-gmail) wrote :

Possibly they have migrated those fixes into the Ubuntu branch then. I'll test it.

David Henningsson (diwic) wrote :

@Lennart: A few days ago, the Kernel Team announced that they will compile a snapshot of latest ALSA [1], and make it available through a package named linux-backports-modules-alsa-karmic. So solving the bug might be as easy as installing this package, and I'm sure they'll be happy for testers.

[1] https://lists.ubuntu.com/archives/kernel-team/2009-October/007611.html

Niels Ganser (niels.io) wrote :

Thanks, David.

linux-backports-modules-alsa-karmic does indeed fix the issue on my Macbook 3,1 running karmic. The backport also fixes headphone detection trouble, e.g. speakers are now reliably muted when something is plugged into the headphone jack.

This can probably be closed as fix committed though ALSA still tracks the issue as "new", presumably due to a lack of positive test reports.

Lennart Regebro (regebro-gmail) wrote :

I can confirm that the bug is fixed. I didn't even need to enable backports.

Daniel T Chen (crimsun) wrote :

Thanks for the feedback.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
Sergiojose (sjmp93) on 2009-11-22
Changed in mactel-support:
assignee: nobody → Sergiojose (sjmp93)
assignee: Sergiojose (sjmp93) → nobody
ThOR27 (thor27-gmail) wrote :

I'm having this same problem on a MacBook 5,2

if I use:

model=mb5
Sound works after unmuting HP, but no headphones detection and no subwoofers

model=mbp3
Headphones detection works, sound works but no subwoofers

model=asus-a7m
Headphone detection doesnt works, but subwoofers works and sound seems much cleaner.

I'm with linux-backports-modules-alsa-karmic-generic installed, and no changes with that.

Ubuntu Karmic 9.10 with alsa-backport
MacBook 5,2

Don't know what kind of extra information is needed for this but I can inform if requested.

Thanks.

Changed in alsa-driver:
status: Unknown → New
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.