No Sound on Toshiba Laptop Model Satellite L30

Bug #155939 reported by Narayana on 2007-10-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ALSA driver
In Progress
alsa-driver (Ubuntu)
linux (Ubuntu)
linux-source-2.6.20 (Ubuntu)

Bug Description

The laptop has multi boot options - XP , Fedora 4 , Ubuntu 7.04
The sound is fine with Windows XP.
There is no sound with Fedora / Ubuntu
With lots of hope i tried ubuntu 7.04
I hope that one day in near future I will hear sound with Ubuntu 7.04
I do not want to hear sound with XP

Sound Driver : RealteK
                       : Direct X 9.0c
                       : HD Audio
                       : Codec : ALC861

description: updated
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at I have classified this bug as a bug in linux-source-2.6.20.

Narayana (narayanarao-brs) wrote :

There is no sound any package . No Sound while playing any media like a CD , an MP3 Recording , Sample Files loaded with Installation. There is no System sound at any event eg Log in or Log out . I did not hear even a single Beep.

Narayana (narayanarao-brs) wrote :

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.


2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

krishnan (krishnan-t-tv) wrote :

i have a toshiba l30 laptop. the sound is not working in ubuntu 8.4, hardy. i could not also upgrade it into ubuntu 8.10. the installation failed. when searched, two links specific to my laptop

the exact problem to this specific laptop

the above link also gives a alsa bug page in which several people commented to have successfully patched this. the solution to it is in

when i applied the patch, mentioned therein the above link. in ubuntu, the alsa mixer does not load. it showed a snd_intel module load failure error.

Can anyone test and confirm this is still an issue with the latest pre-release of Jaunty - . You should be able to test via a LiveCD. Please let us know your results. Thanks.

Andy Whitcroft (apw) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Incomplete → Won't Fix
basillea (basillea) wrote :

I have a Toshiba L30 with Jaunty installed and the issue is still present.

Changed in linux-source-2.6.20 (Ubuntu):
status: Won't Fix → New
basillea (basillea) on 2009-10-27
Changed in linux (Ubuntu):
status: Won't Fix → New
Sergio Zanchetta (primes2h) wrote :

Feisty Fawn 7.04 has reached it's end of life more than one year ago.
Please don't reopen closed bugs.

Changed in linux-source-2.6.20 (Ubuntu):
status: New → Won't Fix
Changed in linux (Ubuntu):
status: New → Won't Fix
Sergio Zanchetta (primes2h) wrote :

Why did you close the linux task without an explanation?
A user reported it's still an issue in Jaunty, which is currently still supported.

Changed in linux (Ubuntu):
status: Won't Fix → New
Leo (leorolla) wrote :

Do you experience this problem with Ubuntu 10.04?

Changed in linux (Ubuntu):
status: New → Incomplete
Glenn Ramsey (glennr) wrote :

I had this problem on 10.04. It was fixed it by adding

options snd-hda-intel model=asus-laptop

to /etc/modprobe.d/alsa-base.conf

as described here:

Leo (leorolla) wrote :

Could you open a terminal and run the command below? Thank you.
apport-collect 155939

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Changed in alsa-driver:
status: Unknown → In Progress
Raghavendra (rag-rpg) on 2010-11-06
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Opinion

This is still active under 10.04, 11.10 and 12.04. (Haven't tried under quantal)

Are we any closer to finding the problem?

Debra Virden (teddydlv) on 2013-02-07
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.