Google Chrome can't be docked

Bug #551872 reported by Josh on 2010-03-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
AllTray
Low
Michael B. Trausch
alltray (Ubuntu)
Undecided
Unassigned

Bug Description

Google Chrome (5.0.342.7 beta) doesn't seem to be able to be docked by AllTray (0.69-1ubuntu4) in Ubuntu Karmic (9.10 w/ Gnome). I installed AllTray through Ubuntu's "Ubuntu Software Center." I can dock Firefox and many other programs, just not Chrome. Thanks in advance for the help!

Michael B. Trausch (mtrausch) wrote :

Hi,

Thanks for reporting this bug.

Can you run AllTray with debugging enabled and post the output when trying to run Chrome with it? That would help to see what is going on, since I have neither Chrome 5 beta nor Karmic installed at this point.

Thanks!

Changed in alltray:
status: New → Incomplete
Josh (jrc03c) wrote :

How do I run AllTray with debugging enabled? Pardon my ignorance.

Michael B. Trausch (mtrausch) wrote :

For AllTray 0.69, just add "-d" to the command line options. So, for example, to run Chrome:

 $ alltray -d google-chrome

There are also more options and information in AllTray's man page, which you can see by typing:

 $ man alltray

In a terminal window.

Josh (jrc03c) wrote :

Ah, thank you. Just one quick note: when running the command you suggested, AllTray correctly docks a Chrome window. However, when running a Chrome window normally and trying to use the AllTray GUI to dock it, it doesn't work; I just keep clicking the Chrome window and nothing happens. Okay, here's the debug output:

command without args: google-chrome
basename: google-chrome
command: google-chrome
win->title_time: 0
win->notray: 0
HAVE MANAGER WINDOW
win->libsyp_window id: 113246211
execute program: google-chrome
wait for window
liballtraynomap_filter event: ClientMessage
got window from lib: 117440553
found child window: 117440553
child have pid: 14244
get_window_icon with size request: 30x30
read_rgb_icon --> ok
command_menu->len: 0
have manager window.... now creat_tray.....
get_window_icon with size request: 24x24
read_rgb_icon --> ok
update window title
net_wm_visible_name failed
title: Untitled - Google Chrome
win->title: Untitled - Google Chrome
theme is: Clearlooks
theme name: Clearlooks
theme_file: </home/jrc03c/.themes/Clearlooks/metacity-1/metacity-theme-1.xml>
Failed to read theme from file /home/jrc03c/.themes/Clearlooks/metacity-1/metacity-theme-1.xml: Failed to open file '/home/jrc03c/.themes/Clearlooks/metacity-1/metacity-theme-1.xml': No such file or directory
theme_file: </usr/share/gnome/themes/Clearlooks/metacity-1/metacity-theme-1.xml>
Failed to read theme from file /usr/share/gnome/themes/Clearlooks/metacity-1/metacity-theme-1.xml: Failed to open file '/usr/share/gnome/themes/Clearlooks/metacity-1/metacity-theme-1.xml': No such file or directory
theme_file: </usr/local/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml>
Failed to read theme from file /usr/local/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml: Failed to open file '/usr/local/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml': No such file or directory
theme_file: </usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml>
normal found !
right_titlebar_edge: 4 !
property notify
icon_window_configure_event: 1x24
icon_window_configure_event: 24x24
update_tray_icon: real plug size: 24x24
get_window_icon with size request: 24x24
read_rgb_icon --> ok
icon window press event
exit_call
destroy_all_and_exit
close window

Thanks again for the help.

On 03/30/2010 03:08 PM, Josh wrote:
> Ah, thank you. Just one quick note: when running the command you
> suggested, AllTray correctly docks a Chrome window. However, when
> running a Chrome window normally and trying to use the AllTray GUI to
> dock it, it doesn't work; I just keep clicking the Chrome window and
> nothing happens. Okay, here's the debug output:

Hrm. So you do not start Chrome from AllTray normally, instead you run
AllTray after Chrome? I could see that being a problem, because Chrome
has several processes instead of a single process and the only window
that would really be dockable would be the Chrome top-level window.

I will try to get a VM setup with all the same stuff and see what I can
learn later, but I have the feeling that this might not be a bug in
AllTray, but a limitation of the system.

 --- Mike

--
Michael B. Trausch ☎ (404) 492-6475

Josh (jrc03c) wrote :

Well, to clarify, here's what I usually do. I'll launch an application, click on AllTray in my Gnome menu (which opens that little dialog that asks you to click on a window, and the cursor turns into a cross), and then click on the application window. Usually (like when I try that with Firefox), I have no problem docking just about any window. These steps do not work for Chrome, though. You're probably right; it probably has something to do with how Chrome treats processes. I also read something recently about how Chrome does sandboxing...could that be related?

Similar to the debugging command, I also tried starting Chrome with AllTray at the same time from the terminal with:

  $ alltray -s google-chrome

This worked successfully and without error. Does that answer your question? Any thoughts?

Michael B. Trausch (mtrausch) wrote :

It solidifies my thought that the problem might be related to the multiprocess model that Chrome uses, yes. I'll try to get something setup to test this notion later, and also test against the development release and see if it is a problem there. At this point, I don't yet have enough information to be able to say whether or not this is a bug in AllTray, but I'm going to have to figure the rest out through testing, I think. Thanks for the additional information!

Changed in alltray:
assignee: nobody → Michael B. Trausch (mtrausch)
importance: Undecided → Low
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alltray (Ubuntu):
status: New → Confirmed
codywohlers (codywohlers) wrote :

I think this is fixed. It works for me.

$ dpkg -l |grep alltray
ii alltray 0.71b-1 amd64

$ dpkg -l |grep chrome
ii google-chrome-stable 33.0.1750.152-1 amd64

$ lsb_release -dc; uname -srm
Description: Linux Mint 16 Petra
Codename: petra
Linux 3.11.0-18-generic x86_64

Changed in alltray (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers