AllTray documentation does not specify all requirements for dockable applications

Bug #532308 reported by Michael B. Trausch on 2010-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AllTray
Medium
Michael B. Trausch

Bug Description

The following question came in on LP Answers for AllTray:

I usually use Alltray with JDownloader (Java app), because the default trayicon has a bug with Karmic that renders the background white. But I noticed the current version of Alltray doesn't work, so it will?

The problem is that JDownloader and JBidWatcher do not set the _NET_WM_PID property on its window(s). This is likely a bug somewhere in the Java stack, and AllTray will be unable to manage the application’s window(s) unless there is a PID associated with them. More details follow.

AllTray uses the _NET_WM_PID window attribute to manage application windows in a couple of different ways. When AllTray is told to attach to an application (e.g., the application is not started by AllTray) it uses the PID to look up the process and monitor it so that if the process exits, AllTray will exit appropriately. In the second situation, when AllTray starts a new process, it uses the _NET_WM_PID attribute of newly created application windows to find the application to bind to. Once it finds the application window, it uses libwnck to find all the application's windows.

As this problem is caused by a bug in the Java software stack, and AllTray’s documentation does not specify all of its requirements for proper operation, the AllTray man page needs to be updated to reflect this fact. Fixing the man page will correct this defect and then this bug report may be closed.

Changed in alltray:
importance: Undecided → Medium
milestone: none → 0.7.5dev
status: New → Confirmed
assignee: nobody → Michael B. Trausch (mtrausch)
Michael B. Trausch (mtrausch) wrote :

The man page specifies that all inter-client communication conventions MUST be followed for AllTray to properly work. This includes _NET_WM_PID and friends, so this is tackled.

Changed in alltray:
status: Confirmed → Fix Committed
Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions