Comment 4 for bug 356516

On Tue, 07 Apr 2009 21:35:11 -0000
mehmet nur olcay <email address hidden> wrote:

> ALLTRAY_DEBUG=ALL alltray -D firefox is opening a new firefox but no
> icon at system tray.
>
> Just tried with kcalc:
>
> `--> ALLTRAY_DEBUG=ALL alltray -D
> kcalc [2009-04-08 00:29:53 EEST] INFO/MISC: Debugging subsystem setup
> complete. [2009-04-08 00:29:53 EEST] INFO/CL: Command line options
> parsed. [2009-04-08 00:29:53 EEST] INFO/MISC: Set WNCK Client Type to
> PAGER [2009-04-08 00:29:53 EEST] INFO/PROCESS: Child process 27997
> (kcalc) now running. [2009-04-08 00:29:53 EEST] INFO/PROCESS: No App
> yet. Waiting for one. [2009-04-08 00:29:53 EEST] INFO/TRAY: Created
> tray icon for PID 27997 [2009-04-08 00:29:53 EEST] INFO/PROCESS: Got
> the
> app.
>
> Until here: application is started up with just a blank icon in the
> system tray. Tried with another app and no app-specific icon in system
> tray, just a blank icon.

Which application was that? The icon used in the system tray is the
icon set by the application for its window; if the application doesn't
set an icon, we don't get one. At least for now. If this turns out to
be a really popular phenomenon than we can try to get an icon a
different way.

> With a mouse hover it shows name. When try to
> minimize application, it goes to on taskbar not system tray. And close
> button results :
>
> (alltray:27996): Gtk-CRITICAL **: gtk_status_icon_set_visible:
> assertion `GTK_IS_STATUS_ICON (status_icon)' failed [2009-04-08
> 00:30:10 EEST] INFO/PROCESS: Child process 27997 (kcalc) died.
> [2009-04-08 00:30:10 EEST] INFO/PROCESS: Cleaning up for child...
> [2009-04-08 00:30:10 EEST] INFO/PROCESS: No more children. Dying.

Correct. Clicking the close button to hide the window isn't yet
implemented (this is in the notes on
https://edge.launchpad.net/alltray/trunk/0.7.1dev below the download
links). Clicking on the tray icon, though, does that work for your
application?

Also, you _may_ want (if you are able) to see if the changes in trunk
fix your problem; I currently am using r39 of lp:alltray (if you pull
with bzr) on GNOME and it works well, though I'm not to the point of
actually making an 0.7.3dev release yet; I'll be doing that as soon as
I can get what used to be called click-mode working.

I don't have a KDE install, though I will try to get one in a VM here
this evening so that I can try to better see what is going on. You
said that this was KDE 4.2.1, is that on (K)Ubuntu Jaunty?

 --- Mike