Comment 3 for bug 356516

mehmet nur olcay (mnurolcay) wrote :

ALLTRAY_DEBUG=ALL alltray -D firefox is opening a new firefox but no icon at system tray.

Just tried with kcalc:

`--> ALLTRAY_DEBUG=ALL alltray -D kcalc
[2009-04-08 00:29:53 EEST] INFO/MISC: Debugging subsystem setup complete.
[2009-04-08 00:29:53 EEST] INFO/CL: Command line options parsed.
[2009-04-08 00:29:53 EEST] INFO/MISC: Set WNCK Client Type to PAGER
[2009-04-08 00:29:53 EEST] INFO/PROCESS: Child process 27997 (kcalc) now running.
[2009-04-08 00:29:53 EEST] INFO/PROCESS: No App yet. Waiting for one.
[2009-04-08 00:29:53 EEST] INFO/TRAY: Created tray icon for PID 27997
[2009-04-08 00:29:53 EEST] INFO/PROCESS: Got the app.

Until here: application is started up with just a blank icon in the system tray. Tried with another app and no app-specific icon in system tray, just a blank icon. With a mouse hover it shows name. When try to minimize application, it goes to on taskbar not system tray. And close button results :

(alltray:27996): Gtk-CRITICAL **: gtk_status_icon_set_visible: assertion `GTK_IS_STATUS_ICON (status_icon)' failed
[2009-04-08 00:30:10 EEST] INFO/PROCESS: Child process 27997 (kcalc) died.
[2009-04-08 00:30:10 EEST] INFO/PROCESS: Cleaning up for child...
[2009-04-08 00:30:10 EEST] INFO/PROCESS: No more children. Dying.