0.7.2dev does not have click-mode

Bug #356516 reported by mehmet nur olcay on 2009-04-06
2
Affects Status Importance Assigned to Milestone
AllTray
Medium
Unassigned

Bug Description

Just tried 0.72dev. when i try to run it in console with just "alltray", i'm getting this error:

The program 'alltray' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 120324 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

When trying to run it with a program as "ALLTRAY_DEBUG=ALL alltray -D firefox":

[2009-04-06 22:01:48 EEST] INFO/MISC: Debugging subsystem setup complete.
[2009-04-06 22:01:48 EEST] INFO/CL: Command line options parsed.
[2009-04-06 22:01:48 EEST] INFO/MISC: Set WNCK Client Type to PAGER
[2009-04-06 22:01:48 EEST] INFO/PROCESS: Child process 21274 (firefox) now running.
The program 'alltray' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 5700 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Using KDE4.2.1

Related branches

Michael B. Trausch (mtrausch) wrote :

Yes, AllTray does not currently have an implementation of Click-Mode in the development trunk. This will be addressed in a future test released; tentatively marking it for the 0.7.3dev release; will re-target it if necessary at some point down the road.

Thank you for your bug report, I forgot to mention this in the release notes for 0.7.2dev.

Changed in alltray:
importance: Undecided → Medium
milestone: none → 0.7.3dev
status: New → Confirmed
summary: - start up fail with 0.72dev
+ 0.7.2dev does not have click-mode
Changed in alltray:
assignee: nobody → mtrausch
Michael B. Trausch (mtrausch) wrote :

This is actually two reports, by the way; though, with the latter part, being unable to run Firefox under KDE with AllTray... well, now, that is interesting. Does the Firefox window ever show up? Does AllTray ever get to displaying an icon in the task bar? Can you try with a smaller and faster-loading program like gcalctool (or its KDE equivalent)?

mehmet nur olcay (mnurolcay) wrote :

ALLTRAY_DEBUG=ALL alltray -D firefox is opening a new firefox but no icon at system tray.

Just tried with kcalc:

`--> ALLTRAY_DEBUG=ALL alltray -D kcalc
[2009-04-08 00:29:53 EEST] INFO/MISC: Debugging subsystem setup complete.
[2009-04-08 00:29:53 EEST] INFO/CL: Command line options parsed.
[2009-04-08 00:29:53 EEST] INFO/MISC: Set WNCK Client Type to PAGER
[2009-04-08 00:29:53 EEST] INFO/PROCESS: Child process 27997 (kcalc) now running.
[2009-04-08 00:29:53 EEST] INFO/PROCESS: No App yet. Waiting for one.
[2009-04-08 00:29:53 EEST] INFO/TRAY: Created tray icon for PID 27997
[2009-04-08 00:29:53 EEST] INFO/PROCESS: Got the app.

Until here: application is started up with just a blank icon in the system tray. Tried with another app and no app-specific icon in system tray, just a blank icon. With a mouse hover it shows name. When try to minimize application, it goes to on taskbar not system tray. And close button results :

(alltray:27996): Gtk-CRITICAL **: gtk_status_icon_set_visible: assertion `GTK_IS_STATUS_ICON (status_icon)' failed
[2009-04-08 00:30:10 EEST] INFO/PROCESS: Child process 27997 (kcalc) died.
[2009-04-08 00:30:10 EEST] INFO/PROCESS: Cleaning up for child...
[2009-04-08 00:30:10 EEST] INFO/PROCESS: No more children. Dying.

On Tue, 07 Apr 2009 21:35:11 -0000
mehmet nur olcay <email address hidden> wrote:

> ALLTRAY_DEBUG=ALL alltray -D firefox is opening a new firefox but no
> icon at system tray.
>
> Just tried with kcalc:
>
> `--> ALLTRAY_DEBUG=ALL alltray -D
> kcalc [2009-04-08 00:29:53 EEST] INFO/MISC: Debugging subsystem setup
> complete. [2009-04-08 00:29:53 EEST] INFO/CL: Command line options
> parsed. [2009-04-08 00:29:53 EEST] INFO/MISC: Set WNCK Client Type to
> PAGER [2009-04-08 00:29:53 EEST] INFO/PROCESS: Child process 27997
> (kcalc) now running. [2009-04-08 00:29:53 EEST] INFO/PROCESS: No App
> yet. Waiting for one. [2009-04-08 00:29:53 EEST] INFO/TRAY: Created
> tray icon for PID 27997 [2009-04-08 00:29:53 EEST] INFO/PROCESS: Got
> the
> app.
>
> Until here: application is started up with just a blank icon in the
> system tray. Tried with another app and no app-specific icon in system
> tray, just a blank icon.

Which application was that? The icon used in the system tray is the
icon set by the application for its window; if the application doesn't
set an icon, we don't get one. At least for now. If this turns out to
be a really popular phenomenon than we can try to get an icon a
different way.

> With a mouse hover it shows name. When try to
> minimize application, it goes to on taskbar not system tray. And close
> button results :
>
> (alltray:27996): Gtk-CRITICAL **: gtk_status_icon_set_visible:
> assertion `GTK_IS_STATUS_ICON (status_icon)' failed [2009-04-08
> 00:30:10 EEST] INFO/PROCESS: Child process 27997 (kcalc) died.
> [2009-04-08 00:30:10 EEST] INFO/PROCESS: Cleaning up for child...
> [2009-04-08 00:30:10 EEST] INFO/PROCESS: No more children. Dying.

Correct. Clicking the close button to hide the window isn't yet
implemented (this is in the notes on
https://edge.launchpad.net/alltray/trunk/0.7.1dev below the download
links). Clicking on the tray icon, though, does that work for your
application?

Also, you _may_ want (if you are able) to see if the changes in trunk
fix your problem; I currently am using r39 of lp:alltray (if you pull
with bzr) on GNOME and it works well, though I'm not to the point of
actually making an 0.7.3dev release yet; I'll be doing that as soon as
I can get what used to be called click-mode working.

I don't have a KDE install, though I will try to get one in a VM here
this evening so that I can try to better see what is going on. You
said that this was KDE 4.2.1, is that on (K)Ubuntu Jaunty?

 --- Mike

Michael B. Trausch (mtrausch) wrote :

Let's move the KDE-related discussion on this bug over to bug 357469, which I have opened for KDE 3.x and 4.x issues in the new line of development for AllTray. As an aside, r39 of lp:alltray will fix Firefox under KDE (at least KDE 4.x), but it doesn't work with KDE applications; they are doing something strange and so AllTray doesn't yet know how to pick them up. Also, there seems to be an issue with KDE and some other window managers wherein the docked and hidden application shows up in the task switcher, but that is likely to just need a simple fix somewhere so that the window isn't eligible for view that way. Going to have to go over the specifications documents yet again and see what I can find.

Michael B. Trausch (mtrausch) wrote :

A fix for this is now in lp:alltray - big difference this iteration is that the user's desire to attach to a process is not implicitly assumed, it must be explicitly specified. See NEWS in the source tree (and the man page in the distribution) for information.

Changed in alltray:
assignee: Michael B. Trausch (mtrausch) → nobody
status: Confirmed → Fix Committed
Changed in alltray:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers