Closing Alfanous a box with "Error 13" appear

Bug #905401 reported by Jonathan Reich Da Fonseca on 2011-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Alfanous - Quranic Search engine
Fix Released
Medium
Assem Chelli (عاصم شلي)

Bug Description

The error box contains the following text
---------------------------------------------------------------------------------
The logfile 'C:\Program Files\Alfanous\Gui.exe.log' could not be opened;
[Error 13] Permission denied: C:\\Program Files\\Alfanous\\Gui.exe.log'
---------------------------------------------------------------------------------
My computer is a Windows Vista
An Acer laptop
Thank you a lot
Jonathan Reich

Changed in alfanous:
importance: Undecided → Medium
status: New → Confirmed

Hello, Jonathan

windows vista doesn't give the permissions of creating new files automatically on C drive. we'll work to release a new windows version sooner

Thank you

Hello, Jonathan

I've fixed the problem but before releasing a new version . we need to test it, can you test it on your Vista?

Changed in alfanous:
status: Confirmed → Fix Committed
Changed in alfanous:
assignee: nobody → Assem Chelli (عاصم شلي) (assem-ch)

*Assalamoaleikhum Assem Chelli*
*Of course I will test with all my pleasure. Now, do you send me the
modified one or where must I download?*
*Waiting
Jonathan

*

Sohaib Afifi (sohaibafifi) wrote :

Salam

The solution of such problem is to redirect the sys.stderr (and possibly sys.stdout) to something of your making.

The simplest way to achieve this would be :

import sys
sys.stdout = open(“my_stdout.log”, “w”)
sys.stderr = open(“my_stderr.log”, “w”)

Salam,

@Sohaib, I will hide errors logging but how to change the permissions of config file in Vista to be writable.

@Jonathan, i released two formats but I'm not sure of them:
1)as a portable application
2)as an Installer
you can find them
here https://sourceforge.net/projects/alfanous/files/Interfaces/AlfanousDesktop/0.4.3/

*Assalamo aleikhum Assem Cheli
Seems that everything is work fine, the error completely disappear. For
what I could see only a little bug yet remains, if I can consider this a
bug: clicking in FILE to click EXIT, this does not responds so, for to
close the program I must click up left near Alfanous logo and after CLOSE.
Or click on X up right side.
But the rest seems fine anyway yet I will go to do a deep test in my
studies and readings today and if anything will appear I will tell you.
Thank you a lot
Salam
Jonathan

*
2011/12/23 Assem Chelli (عاصم شلي) <email address hidden>

> Salam,
>
> @Sohaib, I will hide errors logging but how to change the permissions
> of config file in Vista to be writable.
>
> @Jonathan, i released two formats but I'm not sure of them:
> 1)as a portable application
> 2)as an Installer
> you can find them
> here
> https://sourceforge.net/projects/alfanous/files/Interfaces/AlfanousDesktop/0.4.3/
>
>

Salam,

Thanks Jonathan for testing, we'll see about closing bug

@sohaib , it was resolved by adding a line to nsis installer generating script

AccessControl::GrantOnFile "$INSTDIR\configs" "(BU)" "FullAccess"

*Sorry, not lucky. After some time the error appeared again. Now, if I use
the Gui instead of the exe all works normally. Well, I don't understand
much about computers, for many years that I left computers program.*

Sohaib Afifi (sohaibafifi) wrote :

Salam,
I believe that configurations must be special for each individual system user.
In this case they should be saved on the %appdata% directory not the programfiles.

something like

if the file doesn't exist, copy it from the original (the programfiles one) to the %appdata%\alfanous dir
then work with that copy

Well, also I don't know about the importance of to write in the disk... I
am a zero in this :)

Salam,

I fixed the installer to istall indexes in COMMONFILES and the configurations in APPDATA

the release is here
http://sourceforge.net/projects/alfanous/files/Interfaces/AlfanousDesktop/0.4.3/alfanousInstallerV0.4.3.exe/download

*Assalamaleikhum Assem Chelli
Seems that is working well now, until now the error 13 did not appear and I
am working almost for two hours with the alphanous. Also it closes normally.
But with all of this I don't remember where to get the recitation and the
translation. I am in Sweden and we have not here a Massegid so I am
studying alone and yet I depend of the translation and before it worked. I
am looking in the web but I can't find.
Thank you a lot and may you all be deep Blessed.
*

Wa alaikoum assalam Jonathan

Happy to hear that alfanous is very useful for you.

for translations , I removed them from this release 'cause I'm planning to give the user the oppurtunity of installing only the translations he needs

I suggest you to install the old release : https://sourceforge.net/projects/alfanous/files/latest/download
inchallah sooner we'll add the translations to the next release

*Assalamo aleikhum Assem Chelli
I apologize the so many e-mails I am writing to you but I think that this
is important.
If I install the last version and after I install the before version, as
you told me to do because of the translation, all works normally without
the error 13 be present i.e: the software is able to write in the hard
disk. Now, I must not run the cleaner registry or, at least, running it I
must do not permit to delete some lines about Alfanous, this lines are the
ones of the last Alfanous yet active in the before version installation, as
you know.
I have the Zekr for to perfect my Arab Quranic entonation so, I don't need
too much translations but in fact they are important in Alfanous because
takes less time to get the data for my studies. Anyway, I can also do
another thing that also works great that is to install the before version
in a path and the new version in another path. They don't complain
hahahahaha they don't generate problems and work together in peace.
It is not the most perfect way but this so fantastic software of yours
deserves and my studies and recitations are progressing much faster.
I am not good in languages so I take more time, also I am not young
anymore, sixty years counts on me hahahahahaha but I deep know Portuguese,
Spanish, Italian, French, English and soon my Swedish will be really
perfect. I know much more languages but yet I don't feel free with them
because I only use for to read the classics for Philosophy where I am a Ph
D. So, this way, also Latin, Greek, Sanskrit, Pali, Mandarin Chinese and
Russian.
I am saying this because if you need any translation, free of payment of
course - I never take money for this -, you are free to ask me but in the
ones where I am free with.
Thank you a lot, I renew my apologies because of this so many e-mails and
may you and you all be Blessed.
Oh, I am a Muslim for almost thirty years, my conversion has been in
Portugal.
Salam
Jonathan
*

wa Alaikom Salam ,Dear Jonathan

Happy to hear that from you, it really encourage us to do better and better. for the translations , I'm the one who have to apology . I promise you to find a way to bring them back .

I'll add you in our list of translators , insha allah i'll call you when we need translation to Portuguese , Spanish & Italian.

if you dont mind , give us a review here : https://sourceforge.net/projects/alfanous/reviews/

You are welcome Jonathan , I invite you to use our mailing list for contact us . you can also contact me directly to my email.

Salam,
Assem

*Assalamaleikhum Assem Chelli
Your work, your project, is something very special, the idea is fantastic,
your efforts must be titanic so, may you, you all, win. I may say, that
what you are doing is a fantastic pray, that all you focus in the Word is a
great meditation and adoration, for sure Alla will deep Bless you, you all.
It is a great work indeed.
Salam
Jonathan
*

Salamu Alaikom,

Thank you Jonathan :)

--
Assem

Changed in alfanous:
status: Fix Committed → Fix Released

*Salamu Alaikom
I did decide to remain only with the last version, I must train myself in
feel secure with my Quranic translations so, any doubt I will go to the
dictionary or to Zekr. Anyway, when the option of translation,
transliteration and recitation will came out please tell me.
May you and you all be deep Blessed
Jonathan
*

Salamu Alaikoum,

I am making a special release that contains some translations: English,
French, Russian, Swedish..
I'll package it tomorrow but i can't upload it till the next week because
my home internet connection is very weak to upload a file of 50 mb.

Thank you for your interest in Alfanous Project

Kind regards,
Assem

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers