alacarte crashes when no permission to write ~/.config/menus/*

Bug #92272 reported by Higinio Raventós on 2007-03-14
70
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Alacarte Menu Editor
New
Critical
alacarte (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: alacarte

I am using Feisty. This has been happening to me since Herd1. Everytime I right click on the menus and select "Edit the menus" I get this error.

I can open alacarte through the terminal without problems.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 14 17:00:38 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/alacarte
InterpreterPath: /usr/bin/python2.5
Package: alacarte 0.11.3-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python -OOt /usr/bin/alacarte
ProcCwd: /home/higi
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/alacarte']
SourcePackage: alacarte
Uname: Linux HIGILINUX 2.6.20-10-generic #2 SMP Mon Mar 12 00:02:49 UTC 2007 i686 GNU/Linux

Higinio Raventós (higiraven) wrote :
description: updated
Travis Watkins (amaranth) wrote :

You've got broken permissions in your $HOME directory. You can fix them with chown -R higi:higi ~/.config/menus

Changed in alacarte:
status: Unconfirmed → Rejected
montikiki (montikiki) wrote :

The Travis's way to solute the problem works for me

jyk (jykaminski) wrote :

The same solution worked for me on Gutsy.

More precisely I made the following command:

sudo chown -R jeremy:jeremy ~/.config/menus

kalvi (kalvi) wrote :

Yes, the following command solved the problem for me too (8.04). thx.
sudo chown -R username:username ~/.config/menus

Alexander S. Fomin (sashafl) wrote :

 TanX, that works for me to.

Slucky31 (nicolas-dufaut) wrote :

It works for me too

axotolys (axotolys) wrote :

thanks, it's works for me
ubuntu 8.04

Nelson Head (jnhea) wrote :

This occurred when I tried to edit the Applications Menu. I tried the instruction suggested above, but I still get the same crash. It won't let me edit the Applications Menu. I wanted to add a program which I had just downloaded with the package manager to the applications menu.
Any suggestions?
jnh

map (mapicella-gmail) wrote :

Perfect! Thank you!

8.04

Ryan (ubuntu-draziw) wrote :

Just had this with a 8.10 -> 9.04 alpha system. Same issue of root:root ownership - but the question is how it got that way. I don't think this should be marked invalid.

Ryan (ubuntu-draziw) wrote :

Had this happen on 9.04 too. Issue isn't invalid. Two issues IMHO.
1. How about failing with a message that says what the issue is vs triggering a crash?
2. What is causing the root:root menus ownership change?

Changed in alacarte:
status: Invalid → Confirmed
Andreas Moog (ampelbein) on 2009-03-20
summary: - [apport] alacarte crashed with IOError in save()
+ alacarte crashes when no permission to write ~/.config/menus/*
Andreas Moog (ampelbein) wrote :

Reported the issue upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=576799

1. Yes, a message would be helpful, i've attached a patch to the upstream bugreport.
2. If you happen to run alacarte via sudo/gksudo this could happen.

Changed in alacarte (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in alacarte:
status: Unknown → New
Changed in alacarte:
importance: Unknown → Critical

Hey!

Open message <http://skinrefined.com/act.php?ugz9c>

<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.