Exchange fetchAndRemove sometimes returns null

Bug #912514 reported by Peter Beaman
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Akiban Persistit
Medium
Peter Beaman

Bug Description

PersistitMapStress1 fails intermittently with messages like this:

Finished unit=#1 PersistitMapStress test=PersistitMapStress1 main at ts=8036 - elapsed=5738 - FAILED: value not expected to be null
    8036 Failed test unit=#1 PersistitMapStress test=PersistitMapStress1 main
           value not expected to be null

I didn't track down the responsible code, but I'm pretty sure the contents of _spareValue have been mangled.

Since akiban-server does not use this method the bug is no more than medium priority. But it does need to be fixed before akiban-persistit is released as a standalone library.

Related branches

Peter Beaman (pbeaman)
Changed in akiban-persistit:
status: Confirmed → Fix Committed
Changed in akiban-persistit:
milestone: none → 3.1.0
assignee: nobody → Peter Beaman (pbeaman)
Changed in akiban-persistit:
milestone: 3.1.0 → 3.1.1
Changed in akiban-persistit:
status: Fix Committed → Fix Released
visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers