Missing public constructor for com.persistit.SessionId

Bug #1161062 reported by Peter Beaman on 2013-03-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Akiban Persistit
High
Peter Beaman

Bug Description

The documented method for allowing a thread pool to handle a larger number of sessions is to use the Persistit#setSessionId method to switch among sessions. This method takes a SessionId which should be constructed in behalf of a new session. However, there is no available public API that allows a SessionId to be constructed. The constructor is package-private. It should be public.

Separately, the Persistit#closeSession method sets the sessionId ThreadLocal to null - the element should instead be removed. This method is called only by background threads during Persistit shutdown so no harm seems to be done, but we should not be storing null as the value of the ThreadLocal.

Related branches

Peter Beaman (pbeaman) on 2013-03-27
Changed in akiban-persistit:
assignee: nobody → Peter Beaman (pbeaman)
Changed in akiban-persistit:
status: Confirmed → Fix Committed
milestone: none → 3.2.8
Peter Beaman (pbeaman) on 2013-04-11
Changed in akiban-persistit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers