Interrupt causes Thread to exit without releasing claims

Bug #1032701 reported by Peter Beaman
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Akiban Persistit
Fix Released
High
Peter Beaman

Bug Description

Very intermittent failure in TransactionTest2#transactionsWithInterrupts in which some or all threads receive InUseExceptions. Cause appears to be a failure by a thread that is terminating due to an interrupt to clean up all resources it had claimed.

Marking this as High rather than Critical due to low probability of occurrence, but when it does happen there is no remedy other than to crash and restart Persistit.

Related branches

Revision history for this message
Peter Beaman (pbeaman) wrote :

To reproduce: increase TIMEOUT in TransactionTest2 to a large value and run transactionsWithInterrupts on a multi-core machine.

Peter Beaman (pbeaman)
Changed in akiban-persistit:
assignee: nobody → Peter Beaman (pbeaman)
Peter Beaman (pbeaman)
Changed in akiban-persistit:
status: Confirmed → Fix Committed
Changed in akiban-persistit:
milestone: none → 3.1.5
Peter Beaman (pbeaman)
Changed in akiban-persistit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers