system log - Invalid pattern

Bug #1855207 reported by Sopor
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AirDC++
Undecided
Unassigned

Bug Description

In filelist, Search, RSS Feed and Download queue window (maybe i forgot some) it is possible to use the filter to easy show only what i want to see. When using regex it seems to check if the pattern is correct for every character i type and this will make AirDC slow and it will also fill the system log with an error message. In my case it was: "Invalid pattern: (?i)EE\.(" and the whole system log was full of them. It was more than 260 pages because it generated this error for every character i typed in and it wasn't until i was finished with the regex the error message didn't occur anymore.

It should not repeat the same error message for every entry it compares it to. One time is enough.

AirDC++ 3.60

Sopor (sopor)
Changed in airdcpp:
status: New → Confirmed
Sopor (sopor)
Changed in airdcpp:
status: Confirmed → Fix Committed
Sopor (sopor)
Changed in airdcpp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers