No results error is not working

Reported by Christopher Adams on 2011-06-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aikiframework
Critical
Jakub Jankiewicz

Bug Description

No matter how simple the SQL Query, if the query returns no results, the content of No Results Error is NEVER output.

To confirm:

Create a new widget called 'users' with:
 Select Query: select username from aiki_users where username = 'nobody'
 No Results Error: No user!
 Content: ((username))

Expected output:
 <!--start users(28)-->
  <div id="users">
    No user!
  </div>
<!--users(28) end-->

Actual output:
 <!--start users(28)-->
<div id="users">

</div>

 <!--users(28) end-->

Changed in aikiframework:
milestone: none → 0.9
importance: Undecided → Critical
rejon (rejon) on 2011-06-14
Changed in aikiframework:
status: New → Confirmed
assignee: nobody → rg1024 (rg1024)
rg1024 (rg1024) on 2011-06-14
Changed in aikiframework:
status: Confirmed → Fix Committed

you rule!

On Tue, Jun 14, 2011 at 10:27 AM, rg1024 <email address hidden> wrote:
> ** Changed in: aikiframework
>       Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to
> aikiframework.
> https://bugs.launchpad.net/bugs/797018
>
> Title:
>  No results error is not working
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/797018/+subscriptions
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

Changed in aikiframework:
status: Fix Committed → Fix Released
Jakub Jankiewicz (jcubic) wrote :

In which revision it was fixed? I still have this problem but I don't know if Aiki is upgraded.

This bug is affecting Open Font Library again, even though it's been updated recently.

Who was the last person to update OFLB? Whoever did it last did not commit their changes. It should be a pretty recent version.

Jakub, didn't you last update dev.openfontlibrary.org ?

Looks like version 1153 from running:

bzr revno

First things first, does latest aiki no_results work? Christopher, do
you have a more recent installation and does it work? Brad, you might
have a more recent version as well.

Jon

On Tue, Apr 3, 2012 at 10:18 AM, Christopher Adams <email address hidden> wrote:
> This bug is affecting Open Font Library again, even though it's been
> updated recently.
>
> Who was the last person to update OFLB? Whoever did it last did not
> commit their changes. It should be a pretty recent version.
>
> --
> You received this bug notification because you are a member of Aiki
> Framework Developers, which is subscribed to aikiframework.
> https://bugs.launchpad.net/bugs/797018
>
> Title:
>  No results error is not working
>
> Status in Aiki Framework:
>  Fix Released
>
> Bug description:
>  No matter how simple the SQL Query, if the query returns no results,
>  the content of No Results Error is NEVER output.
>
>  To confirm:
>
>  Create a new widget called 'users' with:
>   Select Query: select username from aiki_users where username = 'nobody'
>   No Results Error: No user!
>   Content: ((username))
>
>  Expected output:
>   <!--start users(28)-->
>    <div id="users">
>      No user!
>    </div>
>  <!--users(28) end-->
>
>  Actual output:
>   <!--start users(28)-->
>  <div id="users">
>
>  </div>
>
>   <!--users(28) end-->
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/797018/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~aikiframework-devel
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~aikiframework-devel
> More help   : https://help.launchpad.net/ListHelp

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Jakub Jankiewicz (jcubic) wrote :

I install lastest AIki and no_result_error is not show up.

I created widget SELECT * FROM aiki_widgets WHERE id > (!(1)!)

maybe fix was not comitted. rg1024 did you commit the fix?

Changed in aikiframework:
status: Fix Released → Confirmed
Changed in aikiframework:
assignee: rg1024 (rg1024) → nobody
assignee: nobody → Jakub Jankiewicz (jcubic)
milestone: 0.9.0 → 0.9.1
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers