Aiki js delete not working on several different installs

Reported by Brad Phillips on 2011-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
aikiframework
High
Aiki Framework Developers

Bug Description

There have been several confirmed reports of once-working methods used to delete records by passing db info to delete widgets using javascript failing. Namely, openclipart, but I've also discovered another instance, in Yumumu.com, where js delete is failing. I'm not sure if it's the version of Aiki that's the issue, or if there are other things connecting these instances of the failures (the same method appears to work on other sites like ScaleJournal).

rejon (rejon) wrote :

what browser and operating system?

BTW, this is showing also how we need that better error management exposed in aiki. Its really biting us in the ass now!

Jon

Changed in aikiframework:
status: New → Confirmed
assignee: nobody → Bassel Safadi (bassel)

FF, Chrome, and Safari all fail to respond to certain instances.

on latest Mac OSX 10.6.7

Can you show us some minimal examples of what is not working?

On Wed 13 Apr 2011 06:22:46 AM CST, Brad Phillips wrote:
> on latest Mac OSX 10.6.7

Bassel Safadi (bassel) wrote :

you mean by Javascript delete the custom code that is written that notify the user before deleting the record? if that's what you mean it's not aiki bug, since it's a widget, also all those sites use same version of jquery

Changed in aikiframework:
status: Confirmed → Invalid

Any idea why multiple instances relying on the same javascript would stop working in certain instances and work in others? On Yumumu, nothing was fiddled with since deploying the site, and deleting across the site is suddenly not working, and it's implementing the same tactic as on ocal.

Bassel Safadi (bassel) wrote :

can you show me the instance that is not working, there are many scenarios including conflict with other javascript in the page or something wrong in the original delete form

Every delete instance on the Yumumu /dashboard is failling. Can you login & try to fire any deletes under the Images or Collections or Stories heading? On the admin side, check out widget 49 (the cp/your-collections widget). It has the delete script in it that's supposed to fire on that cp/your-collections page.

rejon (rejon) wrote :

My guess is what happened is it worked on our dev instance and when it got
moved over to the live site, the version of aiki got an update, and it
busted something.

Brad, the test site is still working: http://yumumu.aikilab.org/ Please find
out if this is the problem.

BTW, that site needs to go behind an .htaccess to hide it. Brad, do you have
access to fix that? Or, I can do...let me know after you've tested it.

http://yumumu.aikilab.org/

Jon

On Wed, Apr 13, 2011 at 3:15 AM, Brad Phillips <email address hidden>wrote:

> Every delete instance on the Yumumu /dashboard is failling. Can you
> login & try to fire any deletes under the Images or Collections or
> Stories heading? On the admin side, check out widget 49 (the cp/your-
> collections widget). It has the delete script in it that's supposed to
> fire on that cp/your-collections page.
>
> --
> You received this bug notification because you are a member of Aiki
> Framework Developers, which is subscribed to aikiframework.
> https://bugs.launchpad.net/bugs/759200
>
> Title:
> Aiki js delete not working on several different installs
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

rejon (rejon) on 2011-06-14
Changed in aikiframework:
assignee: Bassel Safadi (bassel) → Aiki Framework Developers (aikiframework-devel)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers