there is only support for english!

Reported by rejon on 2010-12-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Font Library
Critical
Jakub Jankiewicz
aikiframework
High
rg1024
openclipart
High
Jakub Jankiewicz
sharism
Critical
Jakub Jankiewicz

Bug Description

need chinese and arabic support immediately!

rejon (rejon) on 2010-12-20
Changed in sharism:
milestone: 06 → 07
rejon (rejon) on 2011-02-21
Changed in aikiframework:
milestone: none → 0.9
status: New → Confirmed
importance: Undecided → High
Changed in sharism:
importance: High → Critical
Changed in aikiframework:
assignee: nobody → rejon (rejon)

Where is the db for this? I'll need to manually add a row in the aiki_languages table to get this process started. I could only find the aiki login info in the private accounts page.

It should be created by default. It is something like aiki_dict. Did
you check the page in the wiki about language support.

Jon

On Tue, Mar 22, 2011 at 1:20 PM, Brad Phillips
<email address hidden> wrote:
> Where is the db for this?  I'll need to manually add a row in the
> aiki_languages table to get this process started.  I could only find the
> aiki login info in the private accounts page.
>
> --
> You received this bug notification because you are a member of sharism,
> which is subscribed to sharism.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

Yes, checking the Aiki documentation on adding language support prompted my initial inquiries. There are places in the aiki_languages table for 3 languages by default (English, Arabic, and German), so I would need to manually add space for Chinese. Also, a new field has to be added to the aiki_dict table & a field has to be added to each of the areas where you want to be able to switch content from one language to another.

rejon (rejon) wrote :

Ok, cool

Just make sure to use the chinese language code zh_CN or just zh for chinese.

Ok, if confused brief me in chat, but don't get blocked on any one task...

week of random completion of tasks

Jon

On Tue, Mar 22, 2011 at 2:25 PM, Brad Phillips
<email address hidden> wrote:
> Yes, checking the Aiki documentation on adding language support prompted
> my initial inquiries.   There are places in the aiki_languages table for
> 3 languages by default (English, Arabic, and German), so I would need to
> manually add space for Chinese.  Also, a new field has to be added to
> the aiki_dict table & a field has to be added to each of the areas where
> you want to be able to switch content from one language to another.
>
> --
> You received this bug notification because you are a member of sharism,
> which is subscribed to sharism.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

I need phpmyadmin control for sharism or to increase my command line skills before I can do this. Language support requires some additional fields to be added (especially for Chinese, as that's not one of the 3 default languages provided in aiki installs). Can the Sharism db be added to the fabricatorz.com/phpmyadmin install?

Changed in sharism:
status: Confirmed → Triaged
rejon (rejon) wrote :

increase commandline!

no phpmyadmin. you need to learn mysql comandline:

mysql

You can find the db login info in the config.php file in aiki. That
will allow you run the mysql commandline like:

mysql -u aiki -p DBNAME

Obviously, aiki and DBNAME will have to be replaced with the values in
that config.php file

Then you are in the mysql comandline and you can run sql commands from there.

Its much more powerful and easy than phpmyadmin.

Jon

On Thu, Mar 24, 2011 at 8:44 AM, Brad Phillips
<email address hidden> wrote:
> I need phpmyadmin control for sharism or to increase my command line
> skills before I can do this.  Language support requires some additional
> fields to be added (especially for Chinese, as that's not one of the 3
> default languages provided in aiki installs).  Can the Sharism db be
> added to the fabricatorz.com/phpmyadmin install?
>
> ** Changed in: sharism
>       Status: Confirmed => Triaged
>
> --
> You received this bug notification because you are a member of sharism,
> which is subscribed to sharism.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

rejon (rejon) on 2011-05-26
Changed in aikiframework:
assignee: rejon (rejon) → Jakub Szypulka (jaksz)
rejon (rejon) on 2011-06-27
Changed in aikiframework:
assignee: Jakub Szypulka (jaksz) → rejon (rejon)
Changed in openfontlibrary:
milestone: none → 0.3
status: New → Confirmed
importance: Undecided → High
assignee: nobody → rejon (rejon)
Changed in openfontlibrary:
importance: High → Critical
rejon (rejon) wrote :

Roger submitted bit patch to improve support. We have support still, but not good enough in the widgets IMO. Not a blocker from supporting good designed templates.

rejon (rejon) on 2011-08-05
Changed in openfontlibrary:
milestone: 0.3 → 0.4
status: Confirmed → Triaged
Changed in aikiframework:
status: Confirmed → Triaged
Changed in openfontlibrary:
importance: Critical → Medium
rejon (rejon) on 2011-10-08
Changed in aikiframework:
assignee: rejon (rejon) → rg1024 (rg1024)
status: Triaged → Fix Released
Changed in openclipart:
milestone: none → 3.1
assignee: nobody → Jakub Jankiewicz (jcubic)
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Changed in openfontlibrary:
importance: Medium → Critical
assignee: rejon (rejon) → Brad Phillips (brad-bradphillips)
rejon (rejon) wrote :

after updating aiki, jcubic, need to put your language code into new sharism site

Changed in sharism:
assignee: Brad Phillips (brad-bradphillips) → Jakub Jankiewicz (jcubic)
Changed in sharism:
status: Triaged → Fix Committed
rejon (rejon) wrote :

ok, next steps to get oflb and openclipart live, then use the new translation system on them. very cool jcubic!

Changed in sharism:
status: Fix Committed → Fix Released
Tudor Holton (tudor) on 2011-12-21
tags: added: i18n
rejon (rejon) wrote :

The openfontlibrary test site is almost back up, then jcubic, you can have at it on this one to complete it. I think we should hold off on openclipart to 3.2 release so get the software upgraded and stable.

Changed in openfontlibrary:
assignee: Brad Phillips (brad-bradphillips) → Jakub Jankiewicz (jcubic)
rejon (rejon) on 2012-02-04
Changed in openclipart:
milestone: 3.1 → 3.2
rejon (rejon) wrote :

Soooooooooooooooooooooooooo important to get added to both sites. Jakub, really we need this added. I wonder, can we get added with the new aiki forms support? This will be more modifiable by other aiki hackers than the json-rpc method.

Jakub Jankiewicz (jcubic) wrote :

Aiki forms with complex use is pain or even sometime impossible,
creating a site should be enjoyable not pain. If you or other hacker
want to play with current forms with translation that Roger created
they you can create interface for that, my have 2 widgets your using
forms will have 10 or more.

I think that simpler solution is best, and json-rpc and javascript
front-end is simpler and faster to code when you want manage some
database. I think that displaying stuff from database is in current the
best think that Aiki can so.

It would be nice to have syntax that will be allow to create json-rpc
server and client in one widget, maybe I will create such side project
with my markup and other stuff that will allow to do powerful stuff, I
can name it "bushido" and create it as engine that can be install into
Aiki.

PS: everybody can edit javascript widget that hold front-end and edit
translation.php file which is no different then extension. If you know
internals of Aiki then you can work on that too.

On Sun, 11 Mar 2012 14:29:45 -0000
rejon <email address hidden> wrote:

> Soooooooooooooooooooooooooo important to get added to both sites.
> Jakub, really we need this added. I wonder, can we get added with the
> new aiki forms support? This will be more modifiable by other aiki
> hackers than the json-rpc method.
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) wrote :

Ok we need it asap. Also, please work withbrad on theming it. How also
canwe avoid the nasty pekin translation bugs?

Jon Phillips
bj. +86-187-1003-9974
sf. +1-415-830-3884
http://fabricatorz.com

On Mar 12, 2012 3:26 AM, "Jakub Jankiewicz" <email address hidden>
wrote:

Aiki forms with complex use is pain or even sometime impossible,
creating a site should be enjoyable not pain. If you or other hacker
want to play with current forms with translation that Roger created
they you can create interface for that, my have 2 widgets your using
forms will have 10 or more.

I think that simpler solution is best, and json-rpc and javascript
front-end is simpler and faster to code when you want manage some
database. I think that displaying stuff from database is in current the
best think that Aiki can so.

It would be nice to have syntax that will be allow to create json-rpc
server and client in one widget, maybe I will create such side project
with my markup and other stuff that will allow to do powerful stuff, I
can name it "bushido" and create it as engine that can be install into
Aiki.

PS: everybody can edit javascript widget that hold front-end and edit
translation.php file which is no different then extension. If you know
internals of Aiki then you can work on that too.

On Sun, 11 Mar 2012 14:29:45 -0000
rejon <email address hidden> wrote:

> Soooooooooooooooooooooooooo impo...
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

--
You received this bug notification because you are a member of
Fabricatorz Developers, which is...

Jakub Jankiewicz (jcubic) wrote :

There where no id in aiki_dictionaries I added to Aiki so latest have
it. ANd I will need to modify the tool to use id instead of term when
modify/delete translations.

On Mon, 12 Mar 2012 01:05:37 -0000
rejon <email address hidden> wrote:

> Ok we need it asap. Also, please work withbrad on theming it. How also
> canwe avoid the nasty pekin translation bugs?
>
> Jon Phillips
> bj. +86-187-1003-9974
> sf. +1-415-830-3884
> http://fabricatorz.com
>
> On Mar 12, 2012 3:26 AM, "Jakub Jankiewicz"
> <email address hidden> wrote:
>
> Aiki forms with complex use is pain or even sometime impossible,
> creating a site should be enjoyable not pain. If you or other hacker
> want to play with current forms with translation that Roger created
> they you can create interface for that, my have 2 widgets your using
> forms will have 10 or more.
>
> I think that simpler solution is best, and json-rpc and javascript
> front-end is simpler and faster to code when you want manage some
> database. I think that displaying stuff from database is in current
> the best think that Aiki can so.
>
> It would be nice to have syntax that will be allow to create json-rpc
> server and client in one widget, maybe I will create such side project
> with my markup and other stuff that will allow to do powerful stuff, I
> can name it "bushido" and create it as engine that can be install into
> Aiki.
>
> PS: everybody can edit javascript widget that hold front-end and edit
> translation.php file which is no different then extension. If you know
> internals of Aiki then you can work on that too.
>
>
> On Sun, 11 Mar 2012 14:29:45 -0000
> rejon <email address hidden> wrote:
>
> > Soooooooooooooooooooooooooo impo...
> Jakub Jankiewicz
> twitter: @jcubic
> www: http://jcubic.pl
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) wrote :

Ok, can you work with Brad please to update openfontlibrary please
this week. Jakub, I need you to master updating aiki on openclipart
and openfontlibrary. I should not be necessary for this. You have all
the skills to do this. Let me know if there are questions which I can
answer to help with this. I'm online now, you have all the tools to
make this happen. Just make sure to do backups first!

Jon

On Mon, Mar 12, 2012 at 6:28 PM, Jakub Jankiewicz
<email address hidden> wrote:
> There where no id in aiki_dictionaries I added to Aiki so latest have
> it. ANd I will need to modify the tool to use id instead of term when
> modify/delete translations.
>
> On Mon, 12 Mar 2012 01:05:37 -0000
> rejon <email address hidden> wrote:
>
>> Ok we need it asap. Also, please work withbrad on theming it. How also
>> canwe avoid the nasty pekin translation bugs?
>>
>> Jon Phillips
>> bj. +86-187-1003-9974
>> sf. +1-415-830-3884
>> http://fabricatorz.com
>>
>> On Mar 12, 2012 3:26 AM, "Jakub Jankiewicz"
>> <email address hidden> wrote:
>>
>> Aiki forms with complex use is pain or even sometime impossible,
>> creating a site should be enjoyable not pain. If you or other hacker
>> want to play with current forms with translation that Roger created
>> they you can create interface for that, my have 2 widgets your using
>> forms will have 10 or more.
>>
>> I think that simpler solution is best, and json-rpc and javascript
>> front-end is simpler and faster to code when you want manage some
>> database. I think that displaying stuff from database is in current
>> the best think that Aiki can so.
>>
>> It would be nice to have syntax that will be allow to create json-rpc
>> server and client in one widget, maybe I will create such side project
>> with my markup and other stuff that will allow to do powerful stuff, I
>> can name it "bushido" and create it as engine that can be install into
>> Aiki.
>>
>> PS: everybody can edit javascript widget that hold front-end and edit
>> translation.php file which is no different then extension. If you know
>> internals of Aiki then you can work on that too.
>>
>>
>> On Sun, 11 Mar 2012 14:29:45 -0000
>> rejon <email address hidden> wrote:
>>
>> > Soooooooooooooooooooooooooo impo...
>> Jakub Jankiewicz
>> twitter: @jcubic
>> www: http://jcubic.pl
>>
>>
>
> --
> Jakub Jankiewicz
> twitter: @jcubic
> www: http://jcubic.pl
>
> --
> You received this bug notification because you are a member of
> Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

rejon (rejon) wrote :

jcubic, we need this feature? You have until Friday to get this done.

Jakub Jankiewicz (jcubic) wrote :

I added translation tool it need styling

http://dev.openfontlibrary.org/translation

I added languages: en, pt, es, ru, fr, new languages can be added as well.

Changed in openfontlibrary:
status: Triaged → In Progress
Jakub Jankiewicz (jcubic) wrote :

I also added translation rules editor http://dev.openfontlibrary.org/rules-editor but I don't think it will be needed since OFLB don't have dynamic data that need translation

rejon (rejon) wrote :

Great will look over. There might be dynamic data from font descriptions
and more. Can you talk with brad and cxadams about, also need to make sure
the right librarian group of users and above can help translate.

We will need to check over the whole site for links because translations
use route not root.

Jon Phillips
bj. +86-187-1003-9974
sf. +1-415-830-3884
http://fabricatorz.com

On Mar 29, 2012 4:41 PM, "Jakub Jankiewicz" <email address hidden>
wrote:

I also added translation rules editor http://dev.openfontlibrary.org
/rules-editor but I don't think it will be needed since OFLB don't have
dynamic data that need translation

--
You received this bug notification because you are a member of

Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.

https://bugs.launchpad.net/bugs/692464

Title:
there is only support for english!

To manage notifications about this bug go to:
https://bugs.launchpad.net/aikiframework/+bug/692464/+...

Jakub Jankiewicz (jcubic) wrote :

On Thu, 29 Mar 2012 10:16:31 -0000
rejon <email address hidden> wrote:

> Great will look over. There might be dynamic data from font

if there are some fields in the table they can be added using
rules-editor, probably wiki pages, I already added categories

> descriptions and more. Can you talk with brad and cxadams about, also
> need to make sure the right librarian group of users and above can
> help translate.

OK, What group names those users have?

>
> We will need to check over the whole site for links because
> translations use route not root.

I think it use [root-language] or something like this, I can't find it
on pekin site, I use it as reference.

>
> Jon Phillips
> bj. +86-187-1003-9974
> sf. +1-415-830-3884
> http://fabricatorz.com
>
> On Mar 29, 2012 4:41 PM, "Jakub Jankiewicz"
> <email address hidden> wrote:
>
> I also added translation rules editor http://dev.openfontlibrary.org
> /rules-editor but I don't think it will be needed since OFLB don't
> have dynamic data that need translation
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

>> descriptions and more. Can you talk with brad and cxadams about, also
>> need to make sure the right librarian group of users and above can
>> help translate.

>OK, What group names those users have?

The groups on OFLB are SystemGOD > Secretary > Librarian > Member

Anyone with usergroup Librarian and above should be able to translate the site.

Jakub Jankiewicz (jcubic) wrote :

I changed all [root] to [route] (probably [root-languages] was changed to [route])

I changed translation tool to be able to use by Librarian, Rules editor is set to SystemGOD

rejon (rejon) wrote :

excellent, we need to figure out where the language selector will go.

What pages can we see the translation working?

On Thu, Mar 29, 2012 at 8:56 PM, Jakub Jankiewicz
<email address hidden> wrote:
> I changed all [root] to [route] (probably [root-languages] was changed
> to [route])
>
> I changed translation tool to be able to use by Librarian, Rules editor
> is set to SystemGOD
>
> --
> You received this bug notification because you are a member of
> Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Jakub Jankiewicz (jcubic) wrote :

I put only translation tool, there are no (t( in widgets, I can put some
translations using google translate, for testing.

On Thu, 29 Mar 2012 15:14:50 -0000
rejon <email address hidden> wrote:

> excellent, we need to figure out where the language selector will go.
>
> What pages can we see the translation working?
>
> On Thu, Mar 29, 2012 at 8:56 PM, Jakub Jankiewicz
> <email address hidden> wrote:
> > I changed all [root] to [route] (probably [root-languages] was
> > changed to [route])
> >
> > I changed translation tool to be able to use by Librarian, Rules
> > editor is set to SystemGOD
> >
> > --
> > You received this bug notification because you are a member of
> > Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> > https://bugs.launchpad.net/bugs/692464
> >
> > Title:
> >  there is only support for english!
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) wrote :

sounds good, main thing is the functionality is there and librarians
can edit, then we release, and people can help during the 0.5 cycle,
to make the site translated.

On Thu, Mar 29, 2012 at 11:45 PM, Jakub Jankiewicz
<email address hidden> wrote:
> I put only translation tool, there are no (t( in widgets, I can put some
> translations using google translate, for testing.
>
> On Thu, 29 Mar 2012 15:14:50 -0000
> rejon <email address hidden> wrote:
>
>> excellent, we need to figure out where the language selector will go.
>>
>> What pages can we see the translation working?
>>
>> On Thu, Mar 29, 2012 at 8:56 PM, Jakub Jankiewicz
>> <email address hidden> wrote:
>> > I changed all [root] to [route] (probably [root-languages] was
>> > changed to [route])
>> >
>> > I changed translation tool to be able to use by Librarian, Rules
>> > editor is set to SystemGOD
>> >
>> > --
>> > You received this bug notification because you are a member of
>> > Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
>> > https://bugs.launchpad.net/bugs/692464
>> >
>> > Title:
>> >  there is only support for english!
>> >
>> > To manage notifications about this bug go to:
>> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
>>
>>
>
> --
> Jakub Jankiewicz
> twitter: @jcubic
> www: http://jcubic.pl
>
> --
> You received this bug notification because you are a member of
> Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

Jakub Jankiewicz (jcubic) wrote :

I think that we can improve translations creating adding a way to add
one term to all languages, and function to clone all terms to other
language, so SystemGODs that can edit widgets add (t( can create terms
and librarians will be able translate them. When new language will be
needed we can just add it and clone all terms to new language.

Maybe librarians don't even should see add term, and for SystemGODs
there will be 2 fields context and term and that will add to all
languages for future translation by librarians (or SystemGOD)

This is for the future improvement.

On Thu, 29 Mar 2012 15:56:18 -0000
rejon <email address hidden> wrote:

> sounds good, main thing is the functionality is there and librarians
> can edit, then we release, and people can help during the 0.5 cycle,
> to make the site translated.
>
> On Thu, Mar 29, 2012 at 11:45 PM, Jakub Jankiewicz
> <email address hidden> wrote:
> > I put only translation tool, there are no (t( in widgets, I can put
> > some translations using google translate, for testing.
> >
> > On Thu, 29 Mar 2012 15:14:50 -0000
> > rejon <email address hidden> wrote:
> >
> >> excellent, we need to figure out where the language selector will
> >> go.
> >>
> >> What pages can we see the translation working?
> >>
> >> On Thu, Mar 29, 2012 at 8:56 PM, Jakub Jankiewicz
> >> <email address hidden> wrote:
> >> > I changed all [root] to [route] (probably [root-languages] was
> >> > changed to [route])
> >> >
> >> > I changed translation tool to be able to use by Librarian, Rules
> >> > editor is set to SystemGOD
> >> >
> >> > --
> >> > You received this bug notification because you are a member of
> >> > Fabricatorz Developers, which is subscribed to aikiframework
> >> > 0.9.0. https://bugs.launchpad.net/bugs/692464
> >> >
> >> > Title:
> >> >  there is only support for english!
> >> >
> >> > To manage notifications about this bug go to:
> >> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
> >>
> >>
> >
> > --
> > Jakub Jankiewicz
> > twitter: @jcubic
> > www: http://jcubic.pl
> >
> > --
> > You received this bug notification because you are a member of
> > Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> > https://bugs.launchpad.net/bugs/692464
> >
> > Title:
> >  there is only support for english!
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
>
>

--
Jakub Jankiewicz
twitter: @jcubic
www: http://jcubic.pl

rejon (rejon) wrote :
Download full text (3.3 KiB)

Sounds good, yes, some new functionality for that new admin widget.

So, for now, I guess your translation and rules editor are best bet
for the system.

Please file the other issues, seem more like aiki issues for admin panel.

Jon

On Fri, Mar 30, 2012 at 1:09 AM, Jakub Jankiewicz
<email address hidden> wrote:
> I think that we can improve translations creating adding a way to add
> one term to all languages, and function to clone all terms to other
> language, so SystemGODs that can edit widgets add (t( can create terms
> and librarians will be able translate them. When new language will be
> needed we can just add it and clone all terms to new language.
>
> Maybe librarians don't even should see add term, and for SystemGODs
> there will be 2 fields context and term and that will add to all
> languages for future translation by librarians (or SystemGOD)
>
> This is for the future improvement.
>
> On Thu, 29 Mar 2012 15:56:18 -0000
> rejon <email address hidden> wrote:
>
>> sounds good, main thing is the functionality is there and librarians
>> can edit, then we release, and people can help during the 0.5 cycle,
>> to make the site translated.
>>
>> On Thu, Mar 29, 2012 at 11:45 PM, Jakub Jankiewicz
>> <email address hidden> wrote:
>> > I put only translation tool, there are no (t( in widgets, I can put
>> > some translations using google translate, for testing.
>> >
>> > On Thu, 29 Mar 2012 15:14:50 -0000
>> > rejon <email address hidden> wrote:
>> >
>> >> excellent, we need to figure out where the language selector will
>> >> go.
>> >>
>> >> What pages can we see the translation working?
>> >>
>> >> On Thu, Mar 29, 2012 at 8:56 PM, Jakub Jankiewicz
>> >> <email address hidden> wrote:
>> >> > I changed all [root] to [route] (probably [root-languages] was
>> >> > changed to [route])
>> >> >
>> >> > I changed translation tool to be able to use by Librarian, Rules
>> >> > editor is set to SystemGOD
>> >> >
>> >> > --
>> >> > You received this bug notification because you are a member of
>> >> > Fabricatorz Developers, which is subscribed to aikiframework
>> >> > 0.9.0. https://bugs.launchpad.net/bugs/692464
>> >> >
>> >> > Title:
>> >> >  there is only support for english!
>> >> >
>> >> > To manage notifications about this bug go to:
>> >> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
>> >>
>> >>
>> >
>> > --
>> > Jakub Jankiewicz
>> > twitter: @jcubic
>> > www: http://jcubic.pl
>> >
>> > --
>> > You received this bug notification because you are a member of
>> > Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
>> > https://bugs.launchpad.net/bugs/692464
>> >
>> > Title:
>> >  there is only support for english!
>> >
>> > To manage notifications about this bug go to:
>> > https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions
>>
>>
>
> --
> Jakub Jankiewicz
> twitter: @jcubic
> www: http://jcubic.pl
>
> --
> You received this bug notification because you are a member of
> Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>
> To manage notifications about this bug go to:
> https://b...

Read more...

translation engine is there, just need to expose it.

Changed in openfontlibrary:
status: In Progress → Fix Committed
Changed in openfontlibrary:
status: Fix Committed → Fix Released
rejon (rejon) on 2012-04-23
Changed in openclipart:
status: Triaged → Fix Released
Jakub Jankiewicz (jcubic) wrote :

In ocal it's not fixed we need to add translation tool.

rejon (rejon) wrote :

No, the new functionality is there, I filed a new blueprint for the
language interface for 3.3

On Mon, Apr 23, 2012 at 8:28 PM, Jakub Jankiewicz
<email address hidden> wrote:
> In ocal it's not fixed we need to add translation tool.
>
> --
> You received this bug notification because you are a member of
> Fabricatorz Developers, which is subscribed to aikiframework 0.9.0.
> https://bugs.launchpad.net/bugs/692464
>
> Title:
>  there is only support for english!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/aikiframework/+bug/692464/+subscriptions

--
Jon Phillips 王✳爻气 http://fabricatorz.com ✳ skype: kidproto ✳ irc: rejon
+1.415.830.3884 (global) ✳ +86-187-1003-9974 (beijing)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers