language is by english language name and should be ISO-639-1

Reported by rejon on 2010-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Open Font Library
Medium
rejon
aikiframework
Critical
rejon

Bug Description

Aiki is preferring an english spelling of languages and it should represent, and it should be enforced that aiki supports language codes for language switching and not long ass english names that only english speaking people can read. ISO-639-1 is the standard, and ISO-639-2 is the secondary part for regional differences. This is what everyone in the entire world supports. We should too:

http://www.gnu.org/software/gettext/manual/gettext.html.gz#Usual-Language-Codes

Thus, US English is en_US. English is en or en_EN.

Arabic would be ar, or ar_AR, or saudi arabic would be ar_SA

The underscore and hyphen should be read the same, just like google and every other project in the world uses: so en_US is the same as en-US, and its not case sensitive.

The simplest solution is to use the key 'en' for basic english and 'ar' for basic arabic. Then in the language can have a word like english and arabic, then in another language like arabic, could have arabic translations for word english and arabic.

Make sense? This should be fixed here and on all aiki installations.

rejon (rejon) on 2010-11-22
Changed in aikiframework:
assignee: nobody → Bassel Safadi (bassel)
rejon (rejon) on 2010-12-15
Changed in aikiframework:
milestone: 0.7 → 0.8
Bassel Safadi (bassel) on 2011-02-15
Changed in aikiframework:
milestone: 0.8 → 0.9
rejon (rejon) wrote :

this is my main concern with the language code.

Bassel Safadi (bassel) wrote :

the problem with other languages like arabic, it's not possible to use arabic with any other language without UTF8, I still think it's the best option, wordpress, google, drupal use UTF8

Totally, UTF-8 should be default on all sites, of course.

I'm talking about representation inside the database.

Jon

On Thu, Mar 31, 2011 at 2:25 AM, Bassel Safadi <email address hidden> wrote:
> the problem with other languages like arabic, it's not possible to use
> arabic with any other language without UTF8, I still think it's the best
> option, wordpress, google, drupal use UTF8
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/680269
>
> Title:
>  language is by english language name and should be ISO-639-1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aikiframework/+bug/680269/+subscribe
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

Bassel Safadi (bassel) wrote :

representation inside database should be utf8_general_ci with sql set_chareset to utf8, in our case the database size is doubled since each char is 16bit but still much safer for multi languages, what do you think?

rejon (rejon) wrote :

I don't think we are communicating here.

I mean, the code for the language should be stored somewhere in its short form, which all browsers and language programs like gettext use: ISO-639-1 is the standard, and ISO-639-2 for regional differences.

rejon (rejon) on 2011-05-26
Changed in aikiframework:
assignee: Bassel Safadi (bassel) → Jakub Szypulka (jaksz)
rejon (rejon) on 2011-06-27
Changed in aikiframework:
assignee: Jakub Szypulka (jaksz) → rejon (rejon)
Changed in openfontlibrary:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → rejon (rejon)
milestone: none → 0.3
Changed in openfontlibrary:
importance: High → Critical
rejon (rejon) wrote :

database change.

Changed in aikiframework:
status: Confirmed → Fix Committed
Changed in openfontlibrary:
milestone: 0.3 → 0.4
Changed in openfontlibrary:
importance: Critical → Low
importance: Low → Medium
rejon (rejon) wrote :

Thanks to Roger the latest code is compliant. Just need to roll out on oflb and then of course on aikiframework.org

Changed in openfontlibrary:
status: Confirmed → Fix Committed
rejon (rejon) on 2011-10-08
Changed in openfontlibrary:
status: Fix Committed → Fix Released
Changed in aikiframework:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers