Installation of module failed due to __terp__.py references

Bug #586807 reported by Jan Verlaan on 2010-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenERP Agile Methodology
Critical
Jérôme Bove @ CampToCamp

Bug Description

Installation failed due to references in __terp__.py
where is written:
"update_xml" : [
        "project_view.xml",
        "modec_methodo_view.xml",
        "agile_methodo_support_wizard.xml",
        "project_menu.xml",
        "agile_methodo_support_data.xml",

The files agile_xxx doesn't exist (anymore) and are (re)named
"update_xml" : [
        "project_view.xml",
        "modec_methodo_view.xml",
        "modec_methodo_support_wizard.xml",
        "project_menu.xml",
        "modec_methodo_support_data.xml",

After changing the agile_xxx files in the module directory to modec_xxx the installation went succesfull

Related branches

Jan Verlaan (jan-verlaan) wrote :
Download full text (3.5 KiB)

Above changes resolve installation without demodata.

With demo data still a fatal error exist preventing installation:
Environment Information :
System : Linux-2.6.32-22-generic-x86_64-with-Ubuntu-10.04-lucid
OS Name : posix
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid
Operating System Release : 2.6.32-22-generic
Operating System Version : #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010
Operating System Architecture : 64bit
Operating System Locale : nl_NL.UTF8
Python Version : 2.6.5
OpenERP-Client Version : 5.0.10
Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/netsvc.py", line 247, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/netsvc.py", line 76, in __call__
    return getattr(self, method)(*params)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/service/web_services.py", line 633, in execute
    return self._execute(db, uid, wiz_id, datas, action, context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/service/web_services.py", line 613, in _execute
    return wiz.execute(db, uid, self.wiz_datas[wiz_id], action, context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/wizard/__init__.py", line 178, in execute
    res = self.execute_cr(cr, uid, data, state, context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/wizard/__init__.py", line 73, in execute_cr
    action_res = action(self, cr, uid, data, context)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/addons/base/module/wizard/wizard_module_upgrade.py", line 92, in _upgrade_module
    db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/pooler.py", line 62, in restart_pool
    return get_db_and_pool(db_name, force_demo, status, update_module=update_module)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/pooler.py", line 40, in get_db_and_pool
    addons.load_modules(db, force_demo, status, update_module)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/addons/__init__.py", line 740, in load_modules
    r = load_module_graph(cr, graph, status, report=report)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/addons/__init__.py", line 642, in load_module_graph
    tools.convert_xml_import(cr, m, fp, idref, mode=mode, noupdate=True, **kwargs)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/tools/convert.py", line 874, in convert_xml_import
    obj.parse(doc.getroot())
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/tools/convert.py", line 771, in parse
    self._tags[rec.tag](self.cr, rec, n)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/tools/convert.py", line 735, in _tag_record
    f_val = self.id_get(cr, f_model, f_ref)
  File "/usr/local/lib/python2.6/dist-packages/openerp-server/tools/convert.py", line 756, in id_get
    result = self.pool.get('ir.model.data')._get_id(cr, self.uid, mod, id_str)
  File "/usr/local/lib/python2.6/dist-packages/opene...

Read more...

Jan Verlaan (jan-verlaan) wrote :

to resolve the data.xml issue preventing installation, rename all "modec_methodo_support.xxxx" references

Example:
modec_methodo_support.project_root ==> project_root

Changed in agile-openerp-support:
importance: Undecided → Critical
assignee: nobody → Jérôme Bove @ CampToCamp (jbove-c2c)
status: New → Confirmed
Jan Verlaan (jan-verlaan) wrote :

Please check the previous 2 commits for this branch, they are related to this problem.
it seems that previous solutions are incomplete due to not all references are taken into account.

Changed in agile-openerp-support:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers