Affinity depends on deprecated libgnomeui

Bug #316102 reported by onox on 2009-01-11
2
Affects Status Importance Assigned to Milestone
Affinity
Medium
Matt
Awn Extras
Undecided
Unassigned

Bug Description

Affinity applet depends on a deprecated library: libgnomeui. This should be removed so affinity can build without libgnomeui depends.

Mark Lee (malept) wrote :

Affinity is already desktop-agnostic.

Changed in awn-extras:
status: New → Invalid
Julien Lavergne (gilir) wrote :

Not if you build awn-extras with GNOME support, it's still a problem.

Changed in awn-extras:
status: Invalid → Confirmed
Mark Lee (malept) wrote :

I think the best solution would be to have Awn packages for, say, distro versions shipping GNOME 2.24 and later to configure with --with-desktop=agnostic (as it doesn't touch GConf).

onox (onox) wrote :

Affinity has been removed from the tree since revision 1138 because a maintained version is at https://launchpad.net/affinity.

Changed in awn-extras:
status: Confirmed → Won't Fix
Matt (mjz) wrote :

Adding to affinity because I'd like to eventually get rid of gnome libraries in Affinity.

description: updated
Matt (mjz) wrote :

I've made some progress with this, so marking as 'In Progress.'

Changed in affinity:
assignee: nobody → sharkbaitbobby
importance: Undecided → Medium
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers