[bottom edge] Current bottom edge hint timeout makes it difficult to read the bottom edge action

Bug #1357945 reported by Nekhelesh Ramananthan on 2014-08-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Quick Memo
Low
Stefano Verzegnassi
Ubuntu Clock App
High
Nekhelesh Ramananthan
Ubuntu UX
Medium
Giorgio Venturi
address-book-app
Undecided
Renato Araujo Oliveira Filho
dialer-app
Low
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Undecided
Renato Araujo Oliveira Filho
dialer-app (Ubuntu)
Undecided
Renato Araujo Oliveira Filho

Bug Description

Currently when you open the address book, dialer app, clock app etc, the bottom edge hint is visible and shows what the action is. This hint is hidden after a few seconds. This makes it difficult for the user to understand what the bottom edge does if he didn't read the bottom edge text in time.

In the clock app design at https://docs.google.com/presentation/d/1Kkl7xT8BYo9mT8i3IXh6rPrDlNg6cBxTajahlRYIGlI/edit#slide=id.g18587dd40_029 (Slide 4), the bottom edge text is supposed to show the time to the next alarm. By hiding this hint, it renders that text useless since it is hidden.

-- Solution --
- Hint tab is always displayed by default
- When interacting with the content on screen it collapses (e.g. dialler - typing numbers, address book, clock - scrolling)
- When user stops interacting, it reappears after 5 seconds

https://docs.google.com/a/canonical.com/presentation/d/1YuB3SW5UKI5t9ox4Gc9snsOnFAr1j0PTFjbtK-eLO8w/edit#slide=id.g386935507_0225

summary: - Current bottom edge hint makes it difficult to read the bottom edge
- action
+ Current bottom edge hint timeout makes it difficult to read the bottom
+ edge action
Changed in ubuntu-clock-app:
milestone: none → rtm
summary: - Current bottom edge hint timeout makes it difficult to read the bottom
- edge action
+ [bottom edge] Current bottom edge hint timeout makes it difficult to
+ read the bottom edge action
Changed in ubuntu-ux:
status: New → Opinion
importance: Undecided → Wishlist
assignee: nobody → Olga Kemmet (olga-kemmet)
Changed in ubuntu-ux:
status: Opinion → Confirmed
importance: Wishlist → Low
John Lea (johnlea) on 2014-08-18
Changed in ubuntu-ux:
status: Confirmed → Triaged
Olga Kemmet (olga-kemmet) wrote :

Showing/hiding the bottom edge hint is a tricky one.
The proposal to hide the hint if you scroll up in the screen won't work with all applications. Especially with those, where there is no view to scroll, e.g. dialer app.

The initial idea was to show the hint for the first 3-5 times after launching the app, because user will learn what the bottom edge does.

The recommended solution can be either a combination or change to the following points:
1. Extend the bottom edge collapse to 5sec &/or
2. Only collapse the hint after user starts interacting with the content of the screen; dialer - typing numbers, address book - scrolling, etc

Nekhelesh Ramananthan (nik90) wrote :

Can you decide on a solution and list them in a comment for the address book, dialer and clock app. The developers can then get started on their implementation.

Nekhelesh Ramananthan (nik90) wrote :

Personally I am leaning towards the 2nd solution which is to collapse the hint only when the user starts interacting with the content on the screen since for the clock app the bottom edge text shows a useful text which I feel should be shown all the time instead of hiding it automatically.

Changed in ubuntu-clock-app:
importance: Undecided → High
Olga Kemmet (olga-kemmet) wrote :

Well, since the above mentioned projects are linked to this bug, the developers working on them are very much aware of the situation.
I believe they will start working to fix this issue when best convenient for them.

Olga Kemmet (olga-kemmet) wrote :

We need to define a behaviour which will be best for many application and this can take some time.

I second the second option. Maybe we could have a default focused state for the bottom edge tab.
Once focus is removed, bottom edge hint is hidden.

Bill Filler (bfiller) on 2014-08-28
Changed in dialer-app:
status: New → Triaged
importance: Undecided → Low
Changed in quick-memo:
status: New → Triaged
importance: Undecided → Low
Olga Kemmet (olga-kemmet) wrote :

The 2nd solution it is then.

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in ubuntu-ux:
assignee: Olga Kemmet (olga-kemmet) → Giorgio Venturi (giorgio-venturi)
description: updated
Changed in ubuntu-ux:
importance: Low → Medium
Changed in quick-memo:
milestone: none → 0.3
Changed in ubuntu-clock-app:
status: New → Triaged
Changed in address-book-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → In Progress
Changed in address-book-app (Ubuntu):
status: New → In Progress
Changed in dialer-app:
status: Triaged → Fix Released
status: Fix Released → In Progress
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in dialer-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~phablet-team/address-book-app/staging at revision 299, scheduled for release in address-book-app, milestone Unknown

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+14.10.20140919-0ubuntu1

---------------
address-book-app (0.2+14.10.20140919-0ubuntu1) utopic; urgency=low

  [ Leo Arias ]
  * [PageWithBottomEdge] Consider the drag direction to dismiss or show
    the bottom edge page. [ContactListPage] Implemented empty state
    message on contact list, based on messaging app [ContactViewPage]
    Changed avatar view visuals. [Application] Move app icons as part of
    the package. (LP: #1357945)

  [ Renato Araujo Oliveira Filho ]
  * [PageWithBottomEdge] Consider the drag direction to dismiss or show
    the bottom edge page. [ContactListPage] Implemented empty state
    message on contact list, based on messaging app [ContactViewPage]
    Changed avatar view visuals. [Application] Move app icons as part of
    the package. (LP: #1357945)
 -- Ubuntu daily release <email address hidden> Fri, 19 Sep 2014 17:56:25 +0000

Changed in address-book-app (Ubuntu):
status: In Progress → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
Changed in dialer-app:
status: In Progress → Fix Released
Changed in dialer-app (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-clock-app:
assignee: nobody → Nekhelesh Ramananthan (nik90)
status: Triaged → In Progress
Changed in quick-memo:
status: Triaged → In Progress
assignee: nobody → Stefano Verzegnassi (verzegnassi-stefano)

Fix committed into lp:ubuntu-clock-app at revision 131, scheduled for release in ubuntu-clock-app, milestone rtm

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Changed in quick-memo:
status: In Progress → Fix Committed
Changed in quick-memo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers