[contacts app] In edit mode, we want to have 'Next' as the contextual key instead of return

Bug #1231445 reported by Rachel Liu on 2013-09-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Renato Araujo Oliveira Filho
Ubuntu UX
High
Olga Kemmet
address-book-app
Wishlist
Unassigned
ubuntu-keyboard
Wishlist
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Wishlist
Renato Araujo Oliveira Filho
ubuntu-keyboard (Ubuntu)
Wishlist
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Wishlist
Unassigned

Bug Description

Current situation
There is no current way to get to the next field easily when inputting and return key is not useful when there is only a line of text to be entered

Desired solution
We want to have 'Next' instead of the return key to improve the UX.

Related branches

lp:~renatofilho/ubuntu-keyboard/fix-1231445
Superseded for merging into lp:ubuntu-keyboard
PS Jenkins bot: Approve (continuous-integration) on 2014-04-30
Michael Sheldon: Approve on 2014-04-30
Łukasz Zemczak: Pending requested 2014-04-30
lp:~renatofilho/address-book-app/fix-1231445
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-05-07
Arthur Mello: Approve on 2014-05-01
Rachel Liu (rachelliu) on 2013-09-26
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Rachel Liu (rachelliu)
importance: Undecided → High
Changed in address-book-app:
status: New → Confirmed
importance: Undecided → High
Changed in address-book-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)

Keyboard navigation was introduced on this MR: http://bazaar.launchpad.net/~phablet-team/address-book-app/trunk/revision/113

You should be able to use TAB to navigation btw the fields.

Changed in address-book-app (Ubuntu):
status: Confirmed → Fix Committed

SHIFT + TAB to go back.
SHIFT + "->/<-" To navigate on the field label, when it exists.

Pat McGowan (pat-mcgowan) wrote :

Reopened as this is not a solution on the phone, and does not work in number entry keypad layout.
The next key is I think the preferred solution

Changed in address-book-app (Ubuntu):
status: Fix Committed → Confirmed

Adding ubuntu-keyboard as affected probject since we do not have this functionality on the keyboard yet.

Changed in ubuntu-ui-toolkit:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → In Progress
Changed in address-book-app (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-keyboard:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
status: New → In Progress
Changed in address-book-app:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2014-04-22
Changed in address-book-app:
importance: High → Wishlist
Changed in ubuntu-keyboard:
importance: Undecided → Wishlist
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → Wishlist
Changed in address-book-app (Ubuntu):
importance: High → Wishlist
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Wishlist
Changed in ubuntu-ux:
assignee: Rachel Liu (rachelliu) → Olga Kemmet (olga-kemmet)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+14.10.20140508.1-0ubuntu1

---------------
address-book-app (0.2+14.10.20140508.1-0ubuntu1) utopic; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Colin Watson ]
  * Only build address-book-app{,-dbg} on architectures where it is
    installable, due to the new dependency on qtdeclarative5-ubuntu-
    keyboard-extensions0.1.

  [ Renato Araujo Oliveira Filho ]
  * Send a fake tab press and release when the return key is pressed.
    Modify Enter key visuals to show "Next" when a Input field has
    focus; (LP: #1231445)
  * Does not focus contact first name when opening contact edit view.
    (LP: #1268042)
  * Avoid show online account welcome screen if the app is running with
    arguments. (LP: #1306798)
  * Used contact.DisplayLabel as label for contacts in contactlist. (LP:
    #1235971)
  * Avoid the click on edit toolbar get stole by elements on Flickable
    area. (LP: #1312578)
 -- Ubuntu daily release <email address hidden> Thu, 08 May 2014 15:46:36 +0000

Changed in address-book-app (Ubuntu):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2014-05-27
Changed in ubuntu-keyboard (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-keyboard:
status: In Progress → Fix Released
Changed in address-book-app:
status: In Progress → Fix Released
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Released
John Lea (johnlea) on 2014-07-17
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers