[Address book] Adding a new contact doesn't save their mobile number

Bug #1227361 reported by Nicholas Skaggs on 2013-09-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
address-book-app
Critical
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Critical
Renato Araujo Oliveira Filho
Saucy
Critical
Renato Araujo Oliveira Filho

Bug Description

Adding a new contact and adding a phone number to that contact during creation results in a contact without a phone number. To repeat,

1) Open address book and select add
2) click plus sign next to mobile and enter a number
3) Select save

Result
View contact and see no number exists

Expected
Saved contact with entered phone number

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: address-book-app 0.2+13.10.20130916.1-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.1-0ubuntu4
Architecture: armhf
Date: Wed Sep 18 20:52:49 2013
InstallationDate: Installed on 2013-09-17 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20130917.1)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: address-book-app
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Nicholas Skaggs (nskaggs) wrote :
Omer Akram (om26er) on 2013-09-18
summary: - Adding a new contact doesn't save there mobile number
+ Adding a new contact doesn't save their mobile number

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
summary: - Adding a new contact doesn't save their mobile number
+ [Address book] Adding a new contact doesn't save their mobile number
tags: added: addressbk-aug-2013
Bill Filler (bfiller) wrote :

You the mobile number gets saved correctly when adding a new contact if you enter it in the "Mobile" field that is already expanded by default. However if you leave that one blank and add another Mobile field (by pressing the +) and save it then no phone number is saved.

Probably the same is true for other fields as well. They should all be tested and fixed

Changed in address-book-app (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-app:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in address-book-app:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2013-09-20
Changed in address-book-app (Ubuntu Saucy):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 79, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20130925-0ubuntu1

---------------
address-book-app (0.2+13.10.20130925-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Adding single instance marker to the desktop file.

  [ Tiago Salem Herrmann ]
  * Do not bind mainview to keyboard, so we dont show the toolbar when
    dismissing the osk. (LP: #1199122)

  [ Renato Araujo Oliveira Filho ]
  * Fixed contact disappear from the list when edited. (LP: #1225132)
  * Removed action button arrow. Used icon theme for phone number
    actions. (LP: #1227224)
  * Paint a orange rectangle when item is selected. (LP: #1228371)
  * Disable save button if the field name is empty. (LP: #1227870)
  * Move list view to new contact after creation. (LP: #1199983)
  * Remove the contact detail if this is empty. (LP: #1227361)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 79
 -- Ubuntu daily release <email address hidden> Wed, 25 Sep 2013 06:35:24 +0000

Changed in address-book-app (Ubuntu Saucy):
status: In Progress → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers