[Address book] Undefined contact should appear under '#' at bottom of list

Reported by Christina Li on 2013-08-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Christina Li
address-book-app
Medium
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Medium
Renato Araujo Oliveira Filho
address-book-service (Ubuntu)
Medium
Unassigned

Bug Description

tested 16 sept image: the '#' appears on top of the list, not bottom.
==================================
Currently undefined contacts (eg contacts in non-English) is displayed in a 'undefined' or square category/group heading.

Desired solution:
These contacts should all be displayed at the end of the list, in a group header '#'

Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Christina Li (christina-li)
Rachel Liu (rachelliu) on 2013-08-28
tags: added: addressbk-aug-2013
Bill Filler (bfiller) on 2013-08-29
Changed in address-book-app:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 66, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: Confirmed → Fix Committed
Changed in address-book-app (Ubuntu):
status: New → Fix Committed
Changed in address-book-service (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-service - 0.1.0+13.10.20130916.1-0ubuntu1

---------------
address-book-service (0.1.0+13.10.20130916.1-0ubuntu1) saucy; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Terminate the thread before destroying it to avoid crashes. (LP:
    #1222989)

  [ Tiago Salem Herrmann ]
  * group contacts starting with non A-Z characters into a separate
    section. (LP: #1208514)

  [ Renato Araujo Oliveira Filho ]
  * Implemented support to cancel async request.
  * Fixed cancel query to only notify about the cancelation when the
    query stops.
  * Delete dbus async call when request is cancelled.
  * Use a different event loop during the wait for request to finish.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 70
 -- Ubuntu daily release <email address hidden> Mon, 16 Sep 2013 18:27:47 +0000

Changed in address-book-service (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20130916.1-0ubuntu1

---------------
address-book-app (0.2+13.10.20130916.1-0ubuntu1) saucy; urgency=low

  [ Bill Filler ]
  * fix focus on creation.

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Adjust the delegate sizes per design request.

  [ Tiago Salem Herrmann ]
  * Implement fastscroll on the ContactListView widget.
  * Use contact tag to group contacts. (LP: #1208514)

  [ Renato Araujo Oliveira Filho ]
  * Implement fastscroll on the ContactListView widget.
  * fix focus on creation.
  * Fix ui font size based on design spec. (LP: #1217908)
  * Unfavorite the contact if the favorite number was removed.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 67
 -- Ubuntu daily release <email address hidden> Mon, 16 Sep 2013 18:27:48 +0000

Changed in address-book-app (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in ubuntu-ux:
importance: Undecided → Medium
Christina Li (christina-li) wrote :

bug description updated- '#' should be at bottom of list, not top.

Changed in address-book-app:
status: Fix Committed → Fix Released
Christina Li (christina-li) wrote :

@Rentao- I'm still getting undefined contacts (#) on the top of the list. This should appear at the end of the list, after 'Z'.

Changed in address-book-app:
status: Fix Released → Confirmed
Christina Li (christina-li) wrote :

Changed status to confirm- due to the order of 'undefined contacts' in the list

Bill Filler (bfiller) on 2013-10-03
Changed in address-book-app (Ubuntu):
status: Fix Released → Confirmed
Changed in address-book-service (Ubuntu):
status: Fix Released → Confirmed
summary: - [Address book] Undefined contact should appear under '#'
+ [Address book] Undefined contact should appear under '#' at bottom of
+ list
Changed in address-book-app (Ubuntu):
importance: Undecided → Medium
Changed in address-book-service (Ubuntu):
importance: Undecided → Medium
Changed in address-book-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers