[Address book] Impossible to edit avatar image

Reported by Renato Araujo Oliveira Filho on 2013-08-02
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Christina Li
address-book-app
High
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Undecided
Unassigned
address-book-service (Ubuntu)
Undecided
Unassigned

Bug Description

There is no way to edit contact avatar. There is no design spec to how to proceed with avatar edit action.

Desired solution:
In edit mode, there should be an icon next to the avatar to edit image.
see visual design: https://docs.google.com/a/canonical.com/file/d/0B-DUAjjJ5Rj6alljSXdPS3cwTW8/edit

There is no design spec about how to choose the image? What happens when clicking on the edit button? Any SDK component exists to pick a image?

--- Choosing an image would be part of content picker --- it should be linked to Gallery

John Lea (johnlea) on 2013-08-05
Changed in ubuntu-ux:
assignee: nobody → Christina Li (christina-li)
summary: - Impossible to edit avatar image
+ [Address book] Impossible to edit avatar image
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → Medium
description: updated
description: updated
Rachel Liu (rachelliu) on 2013-08-28
tags: added: addressbk-aug-2013
Bill Filler (bfiller) wrote :

@renato
use the content picker qml api (see system settings app how it chooses background photo) to choose the photo. then you might have to do some work to crop/resize the photo, etc.

Changed in address-book-app:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
Changed in address-book-app:
status: Confirmed → In Progress
tags: added: avengers
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 84, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-service - 0.1.0+13.10.20131001.4-0ubuntu1

---------------
address-book-service (0.1.0+13.10.20131001.4-0ubuntu1) saucy; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Fixed avatar update operation. (LP: #1207774)

  [ Maxim Ermilov ]
  * Implemented sync functions.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 77
 -- Ubuntu daily release <email address hidden> Tue, 01 Oct 2013 21:20:41 +0000

Changed in address-book-service (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20131001.4-0ubuntu1

---------------
address-book-app (0.2+13.10.20131001.4-0ubuntu1) saucy; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Avoid show "undefined" for empty names. (LP: #1227696)
  * * Added a animation when closing the type selector. * Force focus on
    InputField when clicking on the type selector. * Highlight the
    editable item on contact edit page. * Added a margin for field
    details. (LP: #1213975)
  * Added basic organization detail support. (LP: #1207773)
  * Implemented support for avatar editor. (LP: #1207774)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 84
 -- Ubuntu daily release <email address hidden> Tue, 01 Oct 2013 21:20:42 +0000

Changed in address-book-app (Ubuntu):
status: Confirmed → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers