[Address book] new contact should be visible in list after creating

Reported by Bill Filler on 2013-07-10
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Christina Li
address-book-app
Critical
Renato Araujo Oliveira Filho
address-book-app (Ubuntu)
Undecided
Unassigned

Bug Description

After you create a new contact and press save, you are brought back to main contacts list view and the new contact is not visible. You should scroll the list to make the newly created contact visible at the top of the list.

Steps:
- launch address-book-app
- create "New" from toolbar
- fill out the details and press save

Expected results:
- contact saved and list displays the newly created contact

Actual results:
- contact saved but not visible, have to scroll in the list to find it

Related branches

lp:~renatofilho/address-book-app/fix-1199983
Merged into lp:address-book-app at revision 78
PS Jenkins bot: Approve (continuous-integration) on 2013-09-23
Bill Filler: Approve on 2013-09-23
Bill Filler (bfiller) on 2013-07-10
Changed in address-book-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → High
milestone: none → ubuntu-13.07
Changed in address-book-app:
status: New → In Progress
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Christina Li (christina-li)
summary: - new contact should be visible in list after creating
+ [Address book] new contact should be visible in list after creating
Changed in address-book-app (Ubuntu):
status: New → In Progress
status: In Progress → New
Rachel Liu (rachelliu) on 2013-08-28
tags: added: addressbk-aug-2013
Bill Filler (bfiller) wrote :

the sdk bug has been fixed.
@renato please check on the status of https://codereview.qt-project.org/#change,62404 and lets gets this merged

Changed in address-book-app:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 78, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20130925-0ubuntu1

---------------
address-book-app (0.2+13.10.20130925-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Adding single instance marker to the desktop file.

  [ Tiago Salem Herrmann ]
  * Do not bind mainview to keyboard, so we dont show the toolbar when
    dismissing the osk. (LP: #1199122)

  [ Renato Araujo Oliveira Filho ]
  * Fixed contact disappear from the list when edited. (LP: #1225132)
  * Removed action button arrow. Used icon theme for phone number
    actions. (LP: #1227224)
  * Paint a orange rectangle when item is selected. (LP: #1228371)
  * Disable save button if the field name is empty. (LP: #1227870)
  * Move list view to new contact after creation. (LP: #1199983)
  * Remove the contact detail if this is empty. (LP: #1227361)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 79
 -- Ubuntu daily release <email address hidden> Wed, 25 Sep 2013 06:35:24 +0000

Changed in address-book-app (Ubuntu):
status: Confirmed → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers