[address book app] in edit mode toolbar should always be visible (Sheet pattern)

Reported by Bill Filler on 2013-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Christina Li
address-book-app
Medium
Tiago Salem Herrmann
address-book-app (Ubuntu)
Medium
Renato Araujo Oliveira Filho

Bug Description

Can still see toolbar while trying to dismiss OSK. Does this need to be fixed further?
========================================

Desired solution:
- Use the Sheet component from the SDK
- The toolbar would be disabled in the Sheet state (but this should happening automatically if Sheet component is used)

======================================
Per spec, the toolbar should be visible always.
1) as soon as you enter edit mode display Cancel/Done buttons
2) when OSK is visible the toolbar needs to move above the OSK so it's visible (the current phone-app does this correctly)

--------------------------
ux commnet:
The edit mode should use Sheet from the SDK component (currently the buttons are on top, rather than bottom, but is being currently looked at)

Related branches

lp:~renatofilho/address-book-app/fix-1199122
Merged into lp:address-book-app at revision 12
Bill Filler: Approve on 2013-07-12
PS Jenkins bot: Approve (continuous-integration) on 2013-07-12
lp:~renatofilho/address-book-app/fix-1199122-phase2
Merged into lp:address-book-app at revision 42
Gustavo Pichorim Boiko: Approve on 2013-08-02
PS Jenkins bot: Approve (continuous-integration) on 2013-08-02
lp:~tiagosh/address-book-app/fix-1199122
Merged into lp:address-book-app at revision 77
Bill Filler: Approve on 2013-09-23
PS Jenkins bot: Approve (continuous-integration) on 2013-09-11
Bill Filler (bfiller) on 2013-07-08
Changed in address-book-app:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Bill Filler (bfiller) on 2013-07-10
Changed in address-book-app:
milestone: none → ubuntu-13.07
importance: Undecided → Critical
Changed in address-book-app:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 12, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: In Progress → Fix Committed
Christina Li (christina-li) wrote :

This should use the sheet pattern in the SDK not toolbar (however, in the SDK the buttons for 'Cancel' and 'Done' is currently in the header area).

summary: - in edit mode toolbar should always be visible
+ [address book app] in edit mode toolbar should always be visible
description: updated
Changed in ubuntu-ux:
assignee: nobody → Christina Li (christina-li)
status: New → Triaged
status: Triaged → Confirmed
importance: Undecided → High

Fix committed into lp:address-book-app at revision 42, scheduled for release in address-book-app, milestone ubuntu-13.07

summary: - [address book app] in edit mode toolbar should always be visible
+ [address book app] in edit mode toolbar should always be visible (Sheet
+ pattern)

Christina this fix was released on Friday could you check if the applications looks as you expected and close the bug if you are ok with that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20130807-0ubuntu1

---------------
address-book-app (0.2+13.10.20130807-0ubuntu1) saucy; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Implemented support to create new contact from the command line.
  * Fixed new contact view to make sure that all fields has a initial
    default value this will cause the field to appear expanded. (LP:
    #1206051)
  * Replaced contact edit toolbar to a sheet component. (LP: #1199122)
  * * Created MultipleSelectionListView component to handle
    multiselection in a ListView. * Added support to delete multiple
    contacts.
  * Fixed autopilot test. (LP: #1208343)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 44
 -- Ubuntu daily release <email address hidden> Wed, 07 Aug 2013 09:24:54 +0000

Changed in address-book-app (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ux:
status: Confirmed → Fix Committed
description: updated
Christina Li (christina-li) wrote :

Reverted bug back to confirm because implementation did not match Design, please see top of bug description updated with desired solution.

Changed in address-book-app:
status: Fix Committed → Confirmed
Rachel Liu (rachelliu) on 2013-08-28
tags: added: addressbk-aug-2013
Bill Filler (bfiller) wrote :

seems to work according to design now

Changed in address-book-app:
status: Confirmed → Fix Committed
Christina Li (christina-li) wrote :

It's according to design but while trying to dismiss OSK, I can still see the toolbar underneath.

Changed in address-book-app:
status: Fix Committed → Confirmed
description: updated
Changed in address-book-app:
assignee: Renato Araujo Oliveira Filho (renatofilho) → Tiago Salem Herrmann (tiagosh)
Bill Filler (bfiller) wrote :

lowering to medium as it's working but just need to hide the toolbar underneath

Changed in address-book-app:
importance: Critical → Medium
Changed in address-book-app (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → Medium
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Christina Li (christina-li) wrote :

@bill, I think this is a duplication of bug 1217526
https://bugs.launchpad.net/address-book-app/+bug/1217526

can you confirm? if so, please mark this one as duplicated.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:address-book-app at revision 77, scheduled for release in address-book-app, milestone ubuntu-13.07

Changed in address-book-app:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+13.10.20130925-0ubuntu1

---------------
address-book-app (0.2+13.10.20130925-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * Adding single instance marker to the desktop file.

  [ Tiago Salem Herrmann ]
  * Do not bind mainview to keyboard, so we dont show the toolbar when
    dismissing the osk. (LP: #1199122)

  [ Renato Araujo Oliveira Filho ]
  * Fixed contact disappear from the list when edited. (LP: #1225132)
  * Removed action button arrow. Used icon theme for phone number
    actions. (LP: #1227224)
  * Paint a orange rectangle when item is selected. (LP: #1228371)
  * Disable save button if the field name is empty. (LP: #1227870)
  * Move list view to new contact after creation. (LP: #1199983)
  * Remove the contact detail if this is empty. (LP: #1227361)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 79
 -- Ubuntu daily release <email address hidden> Wed, 25 Sep 2013 06:35:24 +0000

Changed in address-book-app (Ubuntu):
status: Confirmed → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
Changed in address-book-app (Ubuntu):
assignee: Tiago Salem Herrmann (tiagosh) → Renato Araujo Oliveira Filho (renatofilho)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers