Privacy settings don't affect Gnome recently-used list.

Bug #992338 reported by Billy Barnes on 2012-05-01
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Activity Log Manager
Medium
Jeremy Bicha
activity-log-manager (Ubuntu)
Medium
Unassigned

Bug Description

Blocking directories or apps, or clearing the history entirely in the Privacy settings pane does not prevent files in those directories or opened by those applications from appearing in the Gnome "Recent Files" list in file open/save dialogs. This second log is stored in "~/.local/share/recently-used.xbel".

While I accept that the activity log manager cannot control the monitoring of each individual program, I expected that it would control the *global* recent files list.

Short term: If there is no way to offer the same control, maybe an option to disable it (writing "gtk-recent-files-max-age=0" to ~/.config/gtk-3.0/settings.ini apparently does that) with an appropriate notice. Also, clearing the zeitgeist history should clear the recently-used history.

Noteworthy: in my searches to make sure my bug report was original, I came across a few people who had the complaint about the "Recent Files" list and I saw a number of replies telling them to use the Privacy pane.

Magnetizer (magnetizer) wrote :

In addition to this, turning "Record Activity" on the privacy settings screen off should also inhibit additions to ~/.local/share/recently-used.xbel.

At this moment I work around the problem by

sudo chattr +i ~/.local/share/recently-used.xbel

which inhibits additions to the recently-used file.

You can change this back by

sudo chattr -i ~/.local/share/recently-used.xbel

so the next item will be added again.

This works but it is cumbersome. It would be nice if the privacy settings could take care of it. Of course, the chattr command has to be run by root which could be a problem for a simple on/off switch.

Simon K (octav14n) on 2013-02-14
Changed in activity-log-manager:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

I'm attaching 2 screenshots from GNOME 3.8's new Privacy panel. It would be great if Ubuntu's Security & Privacy panel would include these features also.

I guess Usage and History is already merged. Something has to be done for "Purge Trash and Temporary Files"

This issue has been solved. For "Purge Trash and Temporary Files" keep an eye on LP #1189313

Changed in activity-log-manager:
assignee: nobody → Jeremy Bicha (jbicha)
status: Confirmed → Fix Committed
milestone: none → 0.9.7
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.7-0ubuntu1

---------------
activity-log-manager (0.9.7-0ubuntu1) saucy; urgency=low

  * New upstream release.
    - System Settings panel has been renamed to "Security and Privacy"
    - New Security tab (LP: #1189313)
    - Incognito Mode now stops GtkRecentManager logging (LP: #992338)
    - Deleting all history also purges entries in GtkRecentManager
      (LP: #992338)
  * Use dh compat 9
  * debian/rules:
    - Disable multiarch direcctories since the System Settings panel doesn't
      work installed there yet
  * debian/patches/02_update_standalone_title.patch:
  * debian/patches/06_add_unity_dash_privacy.patch:
    - Dropped, applied in new release
  * debian/patches/02_dont_show_nonexistant_log_types.patch:
    - Ubuntu doesn't include data loggers for Email or Webpages
      so don't show them in the Include list.
 -- Jeremy Bicha <email address hidden> Wed, 10 Jul 2013 11:17:30 -0400

Changed in activity-log-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in activity-log-manager (Ubuntu):
importance: Undecided → Medium
Changed in activity-log-manager:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers