The .desktop.in files don't match with executable file name

Bug #928946 reported by Manish Sinha (मनीष सिन्हा) on 2012-02-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Activity Log Manager
High
Manish Sinha (मनीष सिन्हा)
activity-log-manager (Ubuntu)
Undecided
Unassigned

Bug Description

The alm.desktop.in and alm--cpanel.desktop.in still contains line

Exec=alm
Icon=alm

AND

Exec=gnome-control-center alm

which needs to be changed to activity-log-manager

Changed in activity-log-manager:
assignee: nobody → Manish Sinha (मनीष सिन्हा) (manishsinha)
importance: Undecided → High
milestone: none → 0.9.1
status: New → Confirmed
Sam_ (and-sam) wrote :

Log manager doesn't open from dash.
WARN 2012-02-08 18:48:47 unity <unknown>:0 Unable to launch alm.desktop: child process »alm« couldn't be executed (file or directory not found).

Jeremy Bicha (jbicha) wrote :

And by the way, I suggest you get rid of the extra line breaks in the .desktop file. Other .desktops on my computer don't have all that extra space. Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu):
status: New → Confirmed

Fixed by changing all occourances of alm to activity-log-manager including

* desktop files
* executable name
* library name
* g-c-c integration panel name
* icon name

Changed in activity-log-manager:
status: Confirmed → Fix Committed
Sam_ (and-sam) wrote :

Not sure if it's related.
Ran alt+f2 insert for example gedit or indicator-weather (because it crashed) they'll open activity-log-manager.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.1-0ubuntu1

---------------
activity-log-manager (0.9.1-0ubuntu1) precise; urgency=low

  * New upstream release:
    - The .desktop.in files don't match with executable file name (LP: #928946)
    - History tab always shows "Are you sure you want to delete the history
      from __ to __" even in all selection (LP: #930742)
    - Folder blacklisting doesn't use valid URI (LP: #899096)
  * debian/watch:
    - point to the new upstream launchpad tarball
 -- Didier Roche <email address hidden> Tue, 14 Feb 2012 10:11:47 +0100

Changed in activity-log-manager (Ubuntu):
status: Confirmed → Fix Released
Sam_ (and-sam) wrote :

Works fine. Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers