Accounts Console autopilot support

Bug #1270264 reported by Nicholas Skaggs on 2014-01-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Online Accounts: Account plugins
Undecided
Unassigned

Bug Description

We need a reliable method of creating test accounts for running as part of autopilot test suites. This requires us to be able to create and authenticate an online account for use during the application test.

Speaking with mardy, it was suggested to use the accounts console plugin. However, we need to ensure access to this is maintained without user prompt.

Per our conversation;

<mardy> balloons: soon we'll enforce access control on the accounts
<mardy> balloons: meaning that before an app will be able to use an account, it needs to ask permissions to the user
<mardy> balloons: and this will involve popping up a UI, and doing some stuff
<balloons> mardy, will there be a way to avoid doing that for our tests?
<mardy> balloons: yes, it makes sense that we add a new parameter to the account-console tool, to add a certain app to the ACL

This bug is to ensure those ACL changes allow us to continue to use the tool once access control lands :-)

Leo Arias (elopio) on 2014-04-28
Changed in account-plugins:
status: New → Confirmed
Nicholas Skaggs (nskaggs) wrote :

Marking this as fixed released, due to the implementation we were able to do inside lp:reminders-app.

Changed in account-plugins:
status: Confirmed → Fix Released
Leo Arias (elopio) wrote :

Not really. What we need is to have either the account-console to be improved and work for all our test cases, or to get a new online-accounts-testability package that provides a python module with the helpers we need.
The solution on reminders app is not good enough for all the cases. We need something similar for facebook tests, and click scope and at the moment without support from the team we will have to duplicate a lot of code.

Changed in account-plugins:
status: Fix Released → Confirmed
David Barth (dbarth) wrote :

@Leo: can you list the set of functions you are missing in account-console to drive further automated testing? From there, we can start adding it to the code, including the work you did on reminders-app (Bug #1319048).

Leo Arias (elopio) wrote :

As of today, we need to be able to add u1 accounts and evernote accounts without the GUI. At some point in the future we will like to test the integration of every plugin with the website or application, so I would expect to have one method per plugin on this online-accounts-testability package.

For now, I would be happy with the methods add_evernote_account, add_evernote_sandbox_account and add_ubuntuone_account, with their respective tests to check that the accounts were successfully added.

The code for these methods just needs to be moved from the evernote and click scope branches into the accounts branch where you want to maintain it. Let me know when you have some time to work on this and I will help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers