Online Accounts: Account plugins

failback-servers for gtalk are misconfigured

Reported by Caio Cezar Zapater de Souza on 2012-11-22
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Online Accounts: Account plugins
Undecided
Unassigned
account-plugins (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

I work behind a firewall and the port 5222 is blocked so the telepathy-gabble need to failback to the server "talkx.l.google.com:443,oldssl" but the file /usr/share/accounts/services/google-im.service are misconfigured.

I fixed and attached a patch.

You can simulate this by blocking the port 5222.

And you can find more information using the command mc-tool that shows the error:

==========================
==== before the correction ====
==========================

$ mc-tool show gabble/jabber/google_2ecom0
     Account: gabble/jabber/google_2ecom0
Display Name: raizdepi
  Normalized: <email address hidden>
     Enabled: enabled
        Icon: im-google-talk
    Connects: only when requested
    Nickname: Caio Cezar
     Service: google-talk

Presences:
   Automatic: available (2) ""
     Current: offline (1) ""
   Requested: available (2) ""
    Changing: yes

Storage:
    Provider: im.telepathy.Account.Storage.UOA
  Identifier: uint32 11
Restrictions: Cannot_Set_Parameters, Cannot_Set_Service

        (bool) require-encryption = true
      (string) server = talk.google.com
       (GStrv) fallback-servers = ["\n talkx.l.google.com", "\n talkx.l.google.com:443,oldssl", "\n talkx.l.google.com:80\"\n "]
       (GStrv) extra-certificate-identities = ["talk.google.com"]
      (string) account = google.com

==========================
==== after the correction ====
==========================

:~$ mc-tool show gabble/jabber/google_2ecom0
     Account: gabble/jabber/google_2ecom0
Display Name: <email address hidden>
     Enabled: enabled
        Icon: im-google-talk
    Connects: only when requested
     Service: google-talk

Presences:
   Automatic: available (2) ""
     Current: offline (1) ""
   Requested: available (2) ""
    Changing: yes

Storage:
    Provider: im.telepathy.Account.Storage.UOA
  Identifier: uint32 14
Restrictions: Cannot_Set_Parameters, Cannot_Set_Service

        (bool) require-encryption = true
      (string) server = talk.google.com
       (GStrv) fallback-servers = ["talkx.l.google.com", "talkx.l.google.com:443,oldssl", "talkx.l.google.com:80"]
       (GStrv) extra-certificate-identities = ["talk.google.com"]
      (string) account = google.com

Related branches

lp:~ken-vandine/account-plugins/lp1081839
Merged into lp:account-plugins at revision 84
PS Jenkins bot: Approve (continuous-integration) on 2012-12-05
David King (community): Approve on 2012-12-05

Sorry I forgot to mention the versions

$ dpkg -l account-plugin-google
||/ Name Version Architecture Description
ii account-plugin-google 0.8-0ubuntu2 i386

$ cat /etc/debian_version
wheezy/sid

$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

The attachment "patch to the file /usr/share/accounts/services/google-im.service" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in account-plugins (Ubuntu Quantal):
status: New → Confirmed
Changed in account-plugins (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package account-plugins - 0.10bzr12.12.10-0ubuntu1

---------------
account-plugins (0.10bzr12.12.10-0ubuntu1) raring; urgency=low

  [ Ken VanDine ]
  * New upstream snapshot
    - Fix from Caio Cezar Zapater de Souza which fixes a typo in the
      google-im.service file that prevented gtalk fallback servers
      from working. (LP: #1081839)
    - Added group settings to microblog service files for friends. These are
      duplicated from the existing gwibber groups, we can drop those once
      friends replaces gwibber in raring.
  * debian/control
    - account-plugin-tools should depend on gir1.2-signon-1.0 and
      gir1.2-accounts-1.0

  [ David King ]
  * debian/control
    - Build-depend on libxml2-utils for XML well-formedness tests
    - Update homepage and VCS location
 -- Ken VanDine <email address hidden> Mon, 10 Dec 2012 16:35:59 -0500

Changed in account-plugins (Ubuntu):
status: Confirmed → Fix Released
Dinçer Kavraal (dkavraal) wrote :

After the patch and restart it fixes. Thank you.
13.04 raring

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers