ubuntu 14.10 desktop throughs plugin error, shows no output in accounts window

Bug #1390928 reported by Randy Olive
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ownCloud online account plugin

Bug Description

After installing:

attempting to add an owncloud account shows a blank window and throws the error:

(unity-control-center:24898): account-plugin-WARNING **: ap_client_load_plugin: module /usr/lib/libaccount-plugin-1.0/providers/libowncloud.so not found: /usr/lib/libaccount-plugin-1.0/providers/libowncloud.so: cannot open shared object file: No such file or directory

(unity-control-center:24898): credentials-cc-panel-CRITICAL **: cc-credentials-authorization-page.vala:54: No valid plugin found for provider owncloud

No further progress is possible in the online accounts window.

OS: Ubuntu 14.10
Installed plugin version: account-plugin-owncloud_0.1-0~17~ubuntu14.10.1_all

description: updated
Revision history for this message
Daniel Holm (danielholm) wrote :

This only seem to be an issue with the online accounts on desktop using Unity 7's system settings. Running the new system-settings (that's used on the touch device) you're able to add ownCloud as an online account.

However, this should still be looked into and see where and if there will be better support for the QML providers.

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

@Daniel So do not you want to enable for Desktop as well? In vivid I got the same error. Because of this issue I have to install Gnome-Online-Account and run it under unity by setting "XDG_CURRENT_DESKTOP" !

Revision history for this message
luca (llucax) wrote :

Also failing to use it in the desktop ubuntu. Looking at the system-settings package makes apt want to pull 150 packages, which seems a bit excessive. @Khurshid, how did you manage to do it via Gnome-Online-Account?

Revision history for this message
luca (llucax) wrote :

Oh, before installing this plugin, I tried gnome-control-center but I didn't have the option for owncloud. Now, after installing the plugin, I tried again and I got the option, I setted up the account via gnome-control-center and it worked fine! Finally! Really cool :)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.