Italian IBAN format

Bug #778668 reported by Stefan Rijnhart (Opener)
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Account Banking Framework
Undecided
Unassigned
Banking Addons
Medium
Unassigned

Bug Description

Hi,

an Italian IBAN we encountered suggested that the expected formatting for this country's IBAN in sepa/iban.py is incorrect. The current format is specified as 'WBBBBBCCCCCCAAAAAAAAAAAAV'.

The IBAN in our data parses correctly against 'WBBBBBCCCCCAAAAAAAAAAAA'. This corresponds to the formatting mentioned on http://en.wikipedia.org/wiki/International_Bank_Account_Number,
'KAAAAABBBBBCCCCCCCCCCCC'.

Cheers,
Stefan.

Related branches

Changed in banking-addons:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
James Jesudason (jamesj) wrote :

I've tested this format against a valid IBAN code and this does not work. It is not ignoring the first 4 characters (IT**) and so it is parsing the string incorrectly.

Revision history for this message
Stefan Rijnhart (Opener) (stefan-opener) wrote :

Hi James,

thank you for testing.

Cheers,
Stefan.

Revision history for this message
Pieter J. Kersten (EduSense BV) (pieterj) wrote :

Hi James, thanks for reporting.

Changed in account-banking:
status: New → Confirmed
Changed in account-banking:
status: Confirmed → Fix Committed
Changed in banking-addons:
status: Confirmed → Triaged
Changed in banking-addons:
status: Triaged → Fix Committed
Revision history for this message
Stefan Rijnhart (Opener) (stefan-opener) wrote :

Although James could not validate the solution I suggested, I privately received the account number that he tried to validate and my suggestion does seem to do the trick.

Pieter, note that your modification to the Italian BBAN format in http://bazaar.launchpad.net/~pieterj/account-banking/5.0/revision/71#account_banking/sepa/iban.py is different from my suggestion and still gives the following error validating Italian IBANs:

account_banking/sepa/iban.py", line 131, in __extract__
    result += value[i+4]
IndexError: string index out of range

The reason for this is that the branch number is still 1 character too long.

Changed in banking-addons:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers