Bubble colors and translucency are not customizable (by user or gtkrc)

Reported by Eitan Isaacson on 2009-02-20
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Aachen
Wishlist
Unassigned
notify-osd (Ubuntu)
Wishlist
Steve Dodier-Lazaro

Bug Description

The foreground and background colors composing the bubble's appearance need to be user customizable. Ideally, they should respect the GTK+ theme, so when the user is using a high-contrast theme the bubbles would be adequately visible.

I think a usable way of going about this is to have some custom themes like "Jaunty", "Happy", "Disco", and have another option called "System Theme" which when used will simply respect the current GTK+ theme.

Mirco Müller (macslow) wrote :

Again that's a design-decision. The defaults are meant to be solid and just right. What's rather more desirable for color/opacity is to dynamically adapt to different scenarios.

Changed in aachen:
assignee: nobody → macslow
importance: Undecided → Wishlist
status: New → Invalid
Changed in notify-osd:
assignee: nobody → macslow
importance: Undecided → Wishlist
status: New → Confirmed
Changed in aachen:
status: Invalid → Confirmed
Eitan Isaacson (eeejay) wrote :

Color is a major access issue. Low vision users, for example, will require specific color combinations to render the notifications usable.

Like you said, the defaults should be solid and just right. But there should be a way to change the defaults.

We believe this is addressed in the implicit use of high contrast
between text and bubble, blurring of the underlying image, and system
font sizes. For the moment, the overlay colour in all of our work will
remain unthemable.

Mark

Why don't we put the colors in the .gtkrc that is built by the theme. This way when someone is running the Human theme they'll get the nice colors that we've defined, but other themes can adjust things for other people.

For instance with the DarkRoom theme the base color of the widgets is not quite black, it has a little bit of brown in it. I think that the notification bubble would look nicer if they would also have a similar amount of brown in them.

I'm afraid that if we don't have some implicit support for theming, people will try to invent it on their own through patching. Which will create more of a mess than if we were to allow for it to be defined in the gtkrc.

If any of those patches are effective, we can consider them. But I don't
want the DX team to spend time on that now. In future, we could set
tinting and opacity preferences across all of the overlays we have in
mind, but for the moment, it's not a priority.

Ted: as someone running Clearlooks, would that mean that Clearlooks would have to define it's own bubble colors, or end up with a gray blob or something? I would really prefer to keep it looking good, black and unthemable (this might also socially force us to focus on good defaults instead of everyone half-fixing it in his little corner).

On Tue, 2009-02-24 at 14:09 +0000, Andreas Nilsson wrote:
> Ted: as someone running Clearlooks, would that mean that Clearlooks
> would have to define it's own bubble colors, or end up with a gray blob
> or something? I would really prefer to keep it looking good, black and
> unthemable (this might also socially force us to focus on good defaults
> instead of everyone half-fixing it in his little corner).

I'd recommend doing it something like other GTK Style parameters. Where
we would effectively load style into the gtkrc by default, but let the
theme gtkrc override it. This way we'd have good defaults, but then let
the themes make it match their design if appropriate.

I'm not sure if this is still being worked on. Just to be sure, I too wish I could change the color to something more eye-catching and less common on the average desktop, like say ... yellow :).

Reason being: Since the switch to notify-osd I tend to miss evolution alarms. Somehow the fading unobtrusive black in my peripheral view too often fails to capture my attention. I find myself constantly checking evolutions alarm icon in the panel instead of relying on the notifications.

Thus being unable to change the color feels like a regression from the old but effective yellow bubbles. IMO importance wishlist doesn't seem appropriate.

Jeremy Nickurak (nickurak) wrote :

Getting the notification bubbles to have a consistent look (and feel!) to the rest of the desktop is important. If i wanted light-text-on-black-backgrounds, I'd make my theme use that. (I do in fact.)

I have to say, from an accessibility viewpoint, not having options to change colors and text is a regression. Users with visual impairments may not be able to read the white on black text used. Others can not read black on white also. Unless you have these impairments, you really don't understand. Please give an easy to use option to change colors, for those of us with impairments.

Changed in notify-osd:
assignee: Mirco Müller (macslow) → Steve Dodier (sidi)
status: Confirmed → In Progress
Steve Dodier-Lazaro (sidi) wrote :
Steve Dodier-Lazaro (sidi) wrote :

I would like to know the status of that bug. Is the patch going to be reviewed some day? Thanks in advance.

MarkieB (ubunt-u-markbenjamin) wrote :

Hi,

Looking at the patch, as well as the apparent 'unthemability' inherited from the understanding of the Open Desktop Specification described at https://wiki.ubuntu.com/NotifyOSD#Bubble%20appearance%20and%20layout

I'm thinking that the reluctance to review/merge could be connected to the fact that the patch demands - as I read it - that a theme have set variables for all the various aspects?

I was initially thinking myself of writing a simpler patch that allowed one simple gconf setting, whether to inherit the color scheme from the theme [ie an override of the 'unthemable' notion], then I suppose the natural would be to simply pick up the 'tooltips' color scheme, for the bubbles? Further to that, as I see the actual location troubles some people, some gconf settings for relative transparency, relative location, etc could be worthwhile?

It'd be intriguing to hear whether a gconf 'override' setting could potentially be acceptable, then it may be worthwhile making a more limited patch that makes themability optional / demands no actual changes to the nature of themes?

Best regards

Mark

David Barth (dbarth) on 2010-09-01
Changed in aachen:
assignee: Mirco Müller (macslow) → nobody
Nicolas Delvaux (malizor) wrote :

Frugalware use this patch.

They want to remove the gconf dependency so notify-osd can be used by xfce4, lxde and others windows managers like Openbox.

This patch allow easy and cross desktop customization through a ".notify-osd" file in the home folder.

Perhaps you should get in touch?

Here is a blog post about this: http://frugalware.org/~devil505/blog/?p=1425

summary: - Bubble colors and translucency are not customizable
+ Bubble colors and translucency are not customizable (by user or gtkrc)
tags: added: patch
affects: notify-osd → notify-osd (Ubuntu)

The attachment "Frugalware patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers