Fallback alert has leftmost button as default

Bug #330091 reported by Matthew Paul Thomas on 2009-02-16
6
Affects Status Importance Assigned to Milestone
Aachen
Undecided
Unassigned
notify-osd (Ubuntu)
High
Cody Russell

Bug Description

alsdorf 0.39ubuntu3, Ubuntu 8.10

1. Trigger a notification that uses actions and a custom icon. (A current example is a Gwibber update.)
2. Press Enter.

What happens: The leftmost button is activated (in the Gwibber case, "Reply").

What should happen: Nothing, because as written in the spec, "None of the buttons should be set as the default." (This is because we can't reasonably guess that any of them are a safe default.)

David Barth (dbarth) on 2009-02-20
Changed in notify-osd:
assignee: nobody → dbarth
importance: Undecided → High
status: New → Confirmed
David Barth (dbarth) on 2009-02-25
Changed in notify-osd:
assignee: dbarth → bratsche
Cody Russell (bratsche) wrote :
Cody Russell (bratsche) on 2009-03-16
Changed in notify-osd:
status: Confirmed → Fix Committed
Changed in aachen:
status: New → Invalid
Cody Russell (bratsche) on 2009-03-17
Changed in notify-osd:
status: Fix Committed → Fix Released
affects: notify-osd → notify-osd (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers