cannot assign Windows-L shortcut to start screensaver

Bug #39399 reported by Niels Endres
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
5-a-day-data
Undecided
Unassigned
gnome-control-center
Fix Released
Medium
control-center (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I cannot assign the Windows-L key combination to lock the screen.

In Sys->Pref->Keyboard I select that 'Meta is assigned to the Win keys'.

In Sys->Pref->Keyboard Shortcuts, I then assign <MOD4>L as the screensaver shortcut.

pressing this keyboard combination does not do anything.

interestingly, if I create this key combination for 'Terminal' it works fine (Windows-L will start terminal). It doesn't work for others (show home folder for example).

Revision history for this message
John Doe (johndoedoejohn) wrote :

Which version of Ubuntu do you have this problem in?

Revision history for this message
Niels Endres (niels-weaklogic) wrote :

Sorry for leaving that out. 6.06 flight 6. I have been applying updates, and it is still an issue.

Revision history for this message
Ante Karamatić (ivoks) wrote :

This has been an issue since Gnome introduced key bindings. Only binding terminal with windows key works. Binding close works, maximize, minimize, etc... That works. But home, e-mail, browser and probably more actions - doesn't.

Changed in gnome-control-center:
status: Unconfirmed → Confirmed
Changed in gnome-control-center:
assignee: nobody → desktop-bugs
Revision history for this message
wolfger (wolfger) wrote :

Nothing to do with 5-a-day-data. Don't even ask how I accidentally did that... Can't see how to remove it, so marking it invalid for that project.

Changed in 5-a-day-data:
status: New → Invalid
Revision history for this message
Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in control-center:
status: Confirmed → Incomplete
Revision history for this message
Bogdan Butnaru (bogdanb) wrote :

It's still an issue on Hardy. I haven't tried Intrepid yet, and I probably won't before the beta release.

Andreas Moog (ampelbein)
Changed in control-center:
status: Incomplete → Confirmed
Revision history for this message
chrisstankevitz (chrisstankevitz) wrote :

Anyone know a workaround for this?

Revision history for this message
chrisstankevitz (chrisstankevitz) wrote :
Revision history for this message
Andreas Moog (ampelbein) wrote :

Fixed in Intrepid

Changed in control-center:
status: Confirmed → Fix Released
Revision history for this message
chrisstankevitz (chrisstankevitz) wrote : Re: [Bug 39399] Re: cannot assign Windows-L shortcut to start screensaver

thank you

--- On Wed, 9/17/08, Andreas Moog <email address hidden> wrote:

> From: Andreas Moog <email address hidden>
> Subject: [Bug 39399] Re: cannot assign Windows-L shortcut to start screensaver
> To: <email address hidden>
> Date: Wednesday, September 17, 2008, 3:22 AM
> Fixed in Intrepid
>
> ** Also affects: gnome-control-center via
> http://bugzilla.gnome.org/show_bug.cgi?id=165343
> Importance: Unknown
> Status: Unknown
>
> ** Changed in: control-center (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> cannot assign Windows-L shortcut to start screensaver
> https://bugs.launchpad.net/bugs/39399
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>
> Status in Statistical data of the 5-a-day project: Invalid
> Status in gnome-control-center: Unknown
> Status in “control-center” source package in Ubuntu:
> Fix Released
>
> Bug description:
> I cannot assign the Windows-L key combination to lock the
> screen.
>
> In Sys->Pref->Keyboard I select that 'Meta is
> assigned to the Win keys'.
>
> In Sys->Pref->Keyboard Shortcuts, I then assign
> <MOD4>L as the screensaver shortcut.
>
> pressing this keyboard combination does not do anything.
>
> interestingly, if I create this key combination for
> 'Terminal' it works fine (Windows-L will start
> terminal). It doesn't work for others (show home
> folder for example).

Changed in gnome-control-center:
status: Unknown → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.